Bug 438276 - ISE on trying to create notification filter
ISE on trying to create notification filter
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Monitoring (Show other bugs)
510
All Linux
low Severity low
: ---
: ---
Assigned To: Devan Goodwin
Preethi Thomas
:
Depends On:
Blocks: 248627
  Show dependency treegraph
 
Reported: 2008-03-19 21:38 EDT by Pradeep Kilambi
Modified: 2008-04-02 20:23 EDT (History)
0 users

See Also:
Fixed In Version: sat510
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-02 20:23:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pradeep Kilambi 2008-03-19 21:38:22 EDT
Description of problem:

When trying to create a notification filer in monitoring tab we get an ISE


Version-Release number of selected component (if applicable):
5.1.0-175

How reproducible:
always

Steps to Reproduce:
1. goto monitoring -> notification -> filters
2. click "create new notification filter"
3. gets an ISE
  
Actual results:
ISE

Expected results:
should be able to create a notification filter

Additional info:

https://test10-64.rhndev.redhat.com/rhn/monitoring/config/notification/FilterCreate.do
Comment 1 Pradeep Kilambi 2008-03-19 22:14:58 EDT
2008-03-19 22:13:58,221 [TP-Processor28] WARN 
org.apache.struts.action.RequestProcessor - Unhandled Exception thrown: class
java.util.NoSuchElementException
2008-03-19 22:13:58,226 [TP-Processor28] ERROR
com.redhat.rhn.frontend.servlets.SessionFilter - Error during transaction.
Rolling back
javax.servlet.ServletException
        at
org.apache.struts.action.RequestProcessor.processException(RequestProcessor.java:535)
        at
org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:433)
        at
org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:236)
        at
com.redhat.rhn.frontend.struts.RhnRequestProcessor.process(RhnRequestProcessor.java:78)
        at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1196)
        at org.apache.struts.action.ActionServlet.doGet(ActionServlet.java:414)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:743)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:856)
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
        at com.redhat.rhn.frontend.servlets.AuthFilter.doFilter(AuthFilter.java:69)
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
        at
com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:142)
        at
com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:58)
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
        at
com.redhat.rhn.frontend.servlets.LocalizedEnvironmentFilter.doFilter(LocalizedEnvironmentFilter.java:63)
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
        at
com.redhat.rhn.frontend.servlets.EnvironmentFilter.doFilter(EnvironmentFilter.java:103)
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
        at
com.redhat.rhn.frontend.servlets.SessionFilter.doFilter(SessionFilter.java:51)
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
        at
com.redhat.rhn.frontend.servlets.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:93)
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
        at
org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:214)
        at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
        at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
        at
org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:198)
        at
org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:152)
        at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
        at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
        at
org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:137)
        at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
        at
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:118)
        at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:102)
        at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
        at
org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
        at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
        at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
        at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:929)
        at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:162)
        at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:300)
        at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:374)
        at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:743)
        at
org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:675)
        at org.apache.jk.common.SocketConnection.runIt(ChannelSocket.java:866)
        at
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684)
        at java.lang.Thread.run(Thread.java:595)
Caused by: java.util.NoSuchElementException
        at java.util.HashMap$HashIterator.nextEntry(HashMap.java:844)
        at java.util.HashMap$KeyIterator.next(HashMap.java:877)
        at
org.hibernate.collection.AbstractPersistentCollection$IteratorProxy.next(AbstractPersistentCollection.java:555)
        at
com.redhat.rhn.frontend.action.monitoring.notification.BaseFilterEditAction.execute(BaseFilterEditAction.java:173)
        at
org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:431)
        ... 51 more
Comment 2 Mike McCune 2008-03-19 23:58:06 EDT
Definitely reproduced this.  I can't find a workaround either :-(

Will investigate cause tomorrow.  Probable something simple.
Comment 3 Devan Goodwin 2008-03-20 12:54:50 EDT
Seems to only occur if user clicking the link is not from the default satellite org.
Comment 4 Devan Goodwin 2008-03-20 17:33:30 EDT
Monitoring scouts stored in the db with a reference to a customer ID. On
satellite however this is always 1 despite the fact that the scout may be used
by other orgs. Modfied the offending code to lookup scouts using the default org
and not depend on the e

Fixed in trunk:

Sending       
code/src/com/redhat/rhn/frontend/action/monitoring/notification/BaseFilterEditAction.java

Sending        code/src/com/redhat/rhn/manager/monitoring/MonitoringManager.java

Transmitting file data ..

Committed revision 138366.


Backported to 5.1:

Sending       
code/src/com/redhat/rhn/frontend/action/monitoring/notification/BaseFilterEditAction.java

Sending        code/src/com/redhat/rhn/manager/monitoring/MonitoringManager.java

Transmitting file data ..

Committed revision 138367.



More fixes:

Sending       
code/src/com/redhat/rhn/domain/monitoring/satcluster/SatClusterFactory.java
Sending       
code/src/com/redhat/rhn/domain/monitoring/satcluster/test/SatClusterTest.java
Sending       
code/src/com/redhat/rhn/frontend/action/monitoring/notification/BaseFilterEditAction.java
Sending        code/src/com/redhat/rhn/manager/monitoring/MonitoringManager.java
Transmitting file data ....
Committed revision 138374.

Backport to 5.1:

Sending       
code/src/com/redhat/rhn/domain/monitoring/satcluster/SatClusterFactory.java
Sending       
code/src/com/redhat/rhn/domain/monitoring/satcluster/test/SatClusterTest.java
Sending       
code/src/com/redhat/rhn/frontend/action/monitoring/notification/BaseFilterEditAction.java
Sending        code/src/com/redhat/rhn/manager/monitoring/MonitoringManager.java
Transmitting file data ....
Committed revision 138375.

Comment 5 Mike McCune 2008-03-21 21:51:46 EDT
on_qa
Comment 6 Preethi Thomas 2008-03-24 10:29:18 EDT
verified
Comment 7 Mike McCune 2008-03-25 17:55:28 EDT
works in stage.
Comment 8 Brandon Perkins 2008-04-02 20:23:32 EDT
5.1 Sat GA so Closed for Current Release.

Note You need to log in before you can comment on or make changes to this bug.