Bug 438288 - aes module in 2.6.18-84.el5 depends on padlock.ko
aes module in 2.6.18-84.el5 depends on padlock.ko
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
All Linux
medium Severity low
: rc
: ---
Assigned To: Red Hat Kernel Manager
Martin Jenner
:
: 437272 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-20 03:36 EDT by Huzaifa S. Sidhpurwala
Modified: 2008-06-19 10:29 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-12 13:58:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Huzaifa S. Sidhpurwala 2008-03-20 03:36:54 EDT
Description of problem:
In RHEL 5.2 beta, kernel version 2.6.18-84.el5. When ever i try to load
the aes module, it tries to load the padlock.ko module and fails.

The aes module seems to have been replaced by aes_generic in 5.2 is this a bug?

Version-Release number of selected component (if applicable):

[root@huzaifas ~]# uname -r
2.6.18-84.el5
[root@huzaifas ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Client release 5.2 Beta (Tikanga)

How reproducible:
[root@huzaifas ~]# modprobe aes
WARNING: Error inserting padlock
(/lib/modules/2.6.18-84.el5/kernel/drivers/crypto/padlock.ko): No such device
[root@huzaifas ~]# lsmod | grep aes
aes_generic            31745  0 
aes_i586               37057  1
Comment 1 Huzaifa S. Sidhpurwala 2008-03-20 05:08:53 EDT
I guess aes module is replaced aes_generic  in 5.2 and aes now implies the
padlock dep. module.
This should be put in the release notes.
Comment 2 Huzaifa S. Sidhpurwala 2008-03-20 05:10:01 EDT
If i wasnt clear on my above comments then:

RHEL 5/5.1
aes = arch independent

RHEL 5.2
aes = dep on padlock
aes_generic = arch independent
Comment 3 Prarit Bhargava 2008-05-12 13:58:45 EDT
Hrmm...

AFAICT, aes_generic does not require the padlock module -- furthermore, the
padlock module is not built in RHEL5.

Closing as WORKSFORME.  Huzaifa, please re-open this BZ if this still doesn't
work for you.

P.
Comment 4 Herbert Xu 2008-05-12 22:54:28 EDT
It doesn't require padlock, but padlock is one of the modules that provide the
alias aes.  Therefore if you load aes on a kernel with padlock built as a module
it will attempt to load the padlock module as well as all other AES
implementations.  Failing to load the padlock module when padlock is not
available is expected and not an error.
Comment 5 Milan Broz 2008-06-19 10:29:02 EDT
*** Bug 437272 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.