Bug 438295 - Newer version of crash needed for MRG kdumps
Newer version of crash needed for MRG kdumps
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: realtime-utilities (Show other bugs)
beta
x86_64 All
low Severity medium
: ---
: ---
Assigned To: Red Hat Real Time Maintenance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-20 05:16 EDT by IBM Bug Proxy
Modified: 2008-05-02 13:11 EDT (History)
1 user (show)

See Also:
Fixed In Version: 4.0-5.0.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-02 13:11:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 43294 None None None Never

  None (edit)
Description IBM Bug Proxy 2008-03-20 05:16:33 EDT
=Comment: #0=================================================
Sripathi Kodi <sripathi@in.ibm.com> - 2008-03-20 04:18 EDT
The version of crash shipped with RHEL5.1 seems to be incompatible with the RHEL
MRG kernel (2.6.24.3-29.el5rt). When I open a kdump using this crash, I get a
number of errors like the following:

crash: invalid kernel virtual address: 805f8f00ffff8102  type: "fill_thread_info"

crash: invalid task address: ffff81022e963974

crash: invalid task address: ffff81022e963a58

crash: invalid kernel virtual address: 0  type: "fill_thread_info"

crash: invalid task address: ffff8100c41b7a68

crash: invalid task address: ffff8100c28e7978


The version of crash on RHEL5.1 is:
[root@llm55 2008-03-13-23:06]# crash -v
crash 4.0-4.6.1

I compiled crash from the latest sources available (crash 4.0-6.1) and that did
not show this error.

I also checked the version of crash available in RHEL5.2 beta and that too did
not show these errors. The crash rpm I tried is crash-4.0-5.0.2.x86_64.rpm

So it looks like newer versions of crash behave better with MRG kernel. Could
you please put the new crash rpm on MRG repo?
Comment 1 IBM Bug Proxy 2008-03-31 07:48:31 EDT
------- Comment From sripathi@in.ibm.com 2008-03-31 07:47 EDT-------
Verified that the repo now contains crash-4.0-5.0.2
Comment 2 Clark Williams 2008-05-02 13:11:32 EDT
closing on our side

Note You need to log in before you can comment on or make changes to this bug.