Bug 438331 - [fix available] Planner crashes on Gantt view when task has Fixed duration and assigned resources
[fix available] Planner crashes on Gantt view when task has Fixed duration an...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: planner (Show other bugs)
5.2
All Linux
low Severity high
: rc
: ---
Assigned To: Caolan McNamara
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-20 09:07 EDT by Alexander Todorov
Modified: 2013-04-12 15:36 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-08 04:01:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sample file which can be used to reproduce the problem (1.62 KB, text/plain)
2008-03-20 09:07 EDT, Alexander Todorov
no flags Details
debug info from Bug buddy (8.12 KB, text/plain)
2008-03-20 09:08 EDT, Alexander Todorov
no flags Details
planner-recource-add-attach-button-missing png file (54.27 KB, image/png)
2008-09-26 02:00 EDT, Satyabrata Maitra
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 358415 None None None Never

  None (edit)
Description Alexander Todorov 2008-03-20 09:07:30 EDT
Description of problem:
Planner crashes on Gantt view when task has Fixed duration and assigned
resources. This happens whe you try to open the attached sample file or follow
the steps to reproduce. Doesn't happen when the task is not "Fixed duration" but
"fixed-work" (seen in the xml file) which is the default.

Version-Release number of selected component (if applicable):
planner-0.14-3

How reproducible:
100%

Steps to Reproduce:
1. Create a new project in planner
2. Add tasks and select the "Fixed duration" checkbox in task properties
3. Add resources
4. Attach  some resources to the task
5. If you haven't been in the Gantt view switch to it and the application will crash
  
Actual results:
Application crash

Expected results:
Normal operation of the application

Additional info:
Comment 1 Alexander Todorov 2008-03-20 09:07:30 EDT
Created attachment 298691 [details]
sample file which can be used to reproduce the problem
Comment 2 Alexander Todorov 2008-03-20 09:08:08 EDT
Created attachment 298693 [details]
debug info from Bug buddy
Comment 3 Caolan McNamara 2008-03-20 09:51:01 EDT
I can't envision it as a last minute candidate for RHEL 5.2 given that the
version of planner in RHEL-5 has been unchanged as 0.14-3 since Aug 08 2006, so
the bug must have been there since then. 
Comment 5 RHEL Product and Program Management 2008-07-21 19:04:40 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 9 Satyabrata Maitra 2008-09-26 02:18:33 EDT
Ok, I have tested this bug, creating new project and adding recourse and assigning the task to the resource and switching to the gantt chart. But application did not crash with the proposed version that claimed the fix!

This bug is Fixed in the proposed version.

Version of the Component Tested :- 
planner-0.14.1-4.el5
planner-devel-0.14.1-4.el5
planner-debuginfo-0.14.1-4.el5
planner-eds-0.14.1-4.el5

But one problem faced, that is, planner-eds-0.14.1-4.el5 is not installing due to the dependencies faliure to install with libeutil.so.0, showing the message in gt - "error: Failed dependencies:
        libeutil.so.0 is needed by planner-eds-0.14.1-4.el5.i386" --
Comment 10 Alexander Todorov 2008-09-26 02:48:21 EDT
(In reply to comment #9)
> But one problem faced, that is, planner-eds-0.14.1-4.el5 is not installing due
> to the dependencies faliure to install with libeutil.so.0, showing the message
> in gt - "error: Failed dependencies:
>         libeutil.so.0 is needed by planner-eds-0.14.1-4.el5.i386" --

Please file a separate bug for the missing dependency and add me to CC. Thanks!
Comment 13 errata-xmlrpc 2008-10-08 04:01:37 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0910.html

Note You need to log in before you can comment on or make changes to this bug.