Bug 438355 - debuginfo-install kdemultimedia-extras drags in non-debuginfo RPMs
debuginfo-install kdemultimedia-extras drags in non-debuginfo RPMs
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-20 11:09 EDT by Philip Ashmore
Modified: 2008-03-30 13:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-30 13:14:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philip Ashmore 2008-03-20 11:09:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.12) Gecko/20080208 Fedora/2.0.0.12-1.fc8 Firefox/2.0.0.12

Description of problem:
I just did a debuginfo-install kdemultimedia-extras.
It seems that somewhere along the dependency resolution phase, non-debuginfo RPMs are being dragged in.

Version-Release number of selected component (if applicable):
yum-utils-1.1.11-1.fc8

How reproducible:
Didn't try


Steps to Reproduce:
1. debuginfo-install kdemultimedia-extras

Actual Results:
--> Running transaction check
---> Package bash-debuginfo.i386 0:3.2-20.fc8 set to be updated
---> Package glib2-debuginfo.i386 0:2.14.6-1.fc8 set to be updated
---> Package akode-debuginfo.i386 0:2.0.2-4.fc8 set to be updated
--> Processing Dependency: libakode_src_resampler.so for package: akode-debuginfo
--> Processing Dependency: libakode_jack_sink.so for package: akode-debuginfo
---> Package taglib-debuginfo.i386 0:1.5-1.fc8 set to be updated
---> Package qt-debuginfo.i386 1:3.3.8b-2.fc8 set to be updated
---> Package arts-debuginfo.i386 8:1.5.9-1.fc8 set to be updated
---> Package kdelibs-debuginfo.i386 6:3.5.9-5.fc8 set to be updated
---> Package kdemultimedia-debuginfo.i386 6:3.5.9-1.fc8 set to be updated
--> Running transaction check
---> Package akode-jack.i386 0:2.0.2-4.fc8 set to be updated
---> Package akode-libsamplerate.i386 0:2.0.2-4.fc8 set to be updated
--> Finished Dependency Resolution


Expected Results:
Only *-debuginfo RPMs get downloaded / installed.


Additional info:
I realize that this looks like a problem with the above *-debuginfo RPMs having improper dependencies, so maybe this is a symptom.
Still debuginfo-install (based on it's name) shouldn't install those non-debuginfo RPMs.
Comment 1 Rex Dieter 2008-03-20 11:31:03 EDT
Is this on x86_64?
Do you currently have kdemultimedia-extras installed?

Because, on the surfact, looks like a combination of misunderstanding 
multilib, or simply not having the main/parent package already installed.
Comment 2 Philip Ashmore 2008-03-20 11:37:44 EDT
I'm using KDE nad had a problem with JuK, part of kdemultimedia-extras.
Comment 3 Philip Ashmore 2008-03-20 11:38:34 EDT
I'm using KDE and had a problem with JuK, part of kdemultimedia-extras.
Comment 4 Rex Dieter 2008-03-20 11:41:25 EDT
Arch?  x86_64?  i386?
Comment 5 Rex Dieter 2008-03-20 11:43:49 EDT
Ah, my guess is that
1.  you have an older akode installed
2.  akode-debuginfo will pull in *all* akode-* subpackages, and you currently
don't have -jack, -libsamplerate installed.
Comment 6 Philip Ashmore 2008-03-20 11:54:29 EDT
All my packages were up-to-date when I ran debuginfo-install.

I decided to install kdemultimedia-extras-debuginfo to pad out a stack trace.
How would the other components that were dragged in contribute to this?
Comment 7 Rex Dieter 2008-03-20 12:14:12 EDT
I'll let Seth confirm (or deny), but I'm pretty sure that when you install
pkg-debuginfo, it'll pull in pkg + pkg-* subpackages (that contain debug
symbols) when doing so.  I think that's what you're seeing here (with
akode-jack, akode-libsamplerate), per
--> Processing Dependency: libakode_src_resampler.so for package: akode-debuginfo
--> Processing Dependency: libakode_jack_sink.so for package: akode-debuginfo
Comment 8 Rex Dieter 2008-03-30 13:14:00 EDT
closing -> notabug (assuming explanation in comment #7 is correct)

Note You need to log in before you can comment on or make changes to this bug.