Bug 438413 - Bond slaves other than eth* are ignored by rgmanager
Bond slaves other than eth* are ignored by rgmanager
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: rgmanager (Show other bugs)
4
All Linux
low Severity low
: ---
: ---
Assigned To: Lon Hohberger
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-20 15:13 EDT by Lon Hohberger
Modified: 2009-04-16 16:36 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0791
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-25 15:16:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lon Hohberger 2008-03-20 15:13:31 EDT
+++ This bug was initially created as a clone of Bug #331661 +++

Description of problem:
When using bonding, the ip.sh script only works with slave interfaces which
start with eth*. It fails to get status on other bonded interfaces, like
for example Infiniband (ib*).

Version-Release number of selected component (if applicable):
rgmanager-2.0.24-1.el5

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

-- Additional comment from lhh@redhat.com on 2007-11-09 15:25 EST --
Could you give me 'ip addr list' for a bonded infiniband configuration?

-- Additional comment from t.pek@bom.gov.au on 2007-11-11 22:06 EST --
We have decided to run without ib bonding so I can't send you the
requested output.  

The problem seems to be with the /usr/share/cluster/ip.sh script
in the findSlaves() function. It only recognizes eth* devices:

----------------------------------------------------------------
 while read line; do
                set - $line
                while [ $# -gt 0 ]; do
                        case $1 in
                        eth*:)
                                interfaces="${1/:/} $interfaces"
                                continue 2
                                ;;
                        esac
                        shift
                done
        done < <( /sbin/ip link list | grep "master $mastif" )
--------------------------------------------------------------------

Our original configuration had a master device bond1 and 2 slave 
devices ib0 and ib1. 


-- Additional comment from lhh@redhat.com on 2007-11-13 11:44 EST --
That's the part I thought was suspect too.



-- Additional comment from kanderso@redhat.com on 2007-11-19 14:57 EST --
All cluster version 5 defects should be reported under red hat enterprise linux
5 product name - not cluster suite.

-- Additional comment from lhh@redhat.com on 2008-03-04 18:11 EST --
Created an attachment (id=296827)
Use position rather than pattern-match for slave devices.


-- Additional comment from lhh@redhat.com on 2008-03-04 18:13 EST --
Note that link detection won't work on non-ethernet devices anyway, so I'm not
sure how much this patch would help.

-- Additional comment from lhh@redhat.com on 2008-03-11 13:15 EST --
interfaces=$(/sbin/ip link list | grep "master $mastif" | awk '{print $2}'})      

should obviate the need for the loop entirely.

-- Additional comment from lhh@redhat.com on 2008-03-11 14:47 EST --
Created an attachment (id=297657)
Better patch.  Slightly more efficient, and functionally-tested
Comment 1 RHEL Product and Program Management 2008-03-20 15:18:02 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 6 errata-xmlrpc 2008-07-25 15:16:04 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0791.html

Note You need to log in before you can comment on or make changes to this bug.