Bug 43844 - bad: I can't install glibc-common-2.2-10.i386.rpm and glibc-2.2-10.i386.rpm
bad: I can't install glibc-common-2.2-10.i386.rpm and glibc-2.2-10.i386.rpm
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-07 12:32 EDT by jgarcia
Modified: 2016-11-24 10:18 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-07 12:32:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jgarcia 2001-06-07 12:32:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)

Description of problem:
When I try to run ./configure after unpacking openldap-stable-20010524.tgz 
I get error message that says:"could not link with POSIX Threads" on 
RedHat 7.  By doing a little research, I found a link that matches the 
same problem that I experiencing, and suggest to install the glibc (2.2.2) 
from RedHat 7.1. This is the link were I found this 
solution:"http://openldap.org/faq/data/cache/546.html".  I downloaded both 
glibc-common-2.2.10.i386.rpm and glibc-2.2-10.i386.rpm.  I tried to 
install glibc-2.2-10.i386.rpm first but I get this message:
"error: failed dependecies:
        glibc-common = 2.2 is needed by glibc-2.2-10"
So I decided to install glibc-common-2.2-10 first, but I got this message:
"error: failed dependencies:
         glibc < 2.2.10 conflicts with glibc-common-2.2.10"
It feel like I am chasing my tail. I even tried installing version 2.2-12 
which is a higher version, but I got the same results.

How reproducible:
Always

Steps to Reproduce:
1.rpm -Uvh glibc-common-2.2-10.i386.rpm 
2.rpm -Uvh glibc-2.2-10.i386.rpm 
3.
	

Actual Results:  1."error: failed dependecies:
        glibc-common = 2.2 is needed by glibc-2.2-10"
2.error: failed dependencies:
         glibc < 2.2.10 conflicts with glibc-common-2.2.10

Additional info:
My current glibc package is "glibc-2.1.92-14".  I don't see any glibc-
common package.
Comment 1 Jakub Jelinek 2001-06-07 16:16:42 EDT
The trick is
rpm -Uvh glibc-2.2-10.*.rpm glibc-common-2.2-10.*.rpm
(it is written in the description for this errata).
The dependencies there ensure that you always had the same version
of glibc and glibc-common (they depend on each other, glibc-common
was created to save space, so that files which were the same in
glibc*.i386.rpm and glibc*.i686.rpm don't get duplicated).

Note You need to log in before you can comment on or make changes to this bug.