Bug 438471 - SMI: RedHat need SMI free solution for kernel
SMI: RedHat need SMI free solution for kernel
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: realtime-kernel (Show other bugs)
beta
x86_64 All
low Severity medium
: ---
: ---
Assigned To: Clark Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-21 03:32 EDT by IBM Bug Proxy
Modified: 2008-07-02 11:27 EDT (History)
1 user (show)

See Also:
Fixed In Version: MRG 1.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-02 11:27:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Userspace SMI bits (20.00 KB, application/octet-stream)
2008-03-31 22:40 EDT, IBM Bug Proxy
no flags Details
Kernel: IBM RTL driver (7.15 KB, text/plain)
2008-03-31 22:40 EDT, IBM Bug Proxy
no flags Details
EDAC refactor (10.90 KB, text/plain)
2008-03-31 22:48 EDT, IBM Bug Proxy
no flags Details
AMD EDAC driver (needs the refactor patch) (83.74 KB, text/plain)
2008-03-31 22:48 EDT, IBM Bug Proxy
no flags Details
EDAC 5000 TMID bit fix (969 bytes, text/plain)
2008-03-31 22:48 EDT, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 43205 None None None Never

  None (edit)
Description IBM Bug Proxy 2008-03-21 03:32:32 EDT
=Comment: #0=================================================
KEITH MANNTHEY <mannthey@us.ibm.com> - 2008-03-17 16:09 EDT
Problem description:

We would like to push all the SMI free bits to RedHat for MRG. This includes
EDAC kernel bits (AMD driver for the most part), BIOS driver kernel bits and
Userspace bits.

This code will be a port of the code from our SR3 release. 

This is a place marker bug at this point.  There are RFC patches on the IBM
RedHat list at this time.
Comment 1 IBM Bug Proxy 2008-03-24 13:48:35 EDT
------- Comment From mannthey@us.ibm.com 2008-03-24 13:41 EDT-------
Just wanted to update:

There is a changed in the EDAC driver that is causing a change in topology on
the LS21.  We are working to find a good solution for the situation.   Once
things are properly sorted we will post the patches here.  We expect this to
happen 1/2 of this week.
Comment 2 IBM Bug Proxy 2008-03-31 22:40:45 EDT
Created attachment 299808 [details]
Userspace SMI bits

untar and run "make install" is our current install method. 

Contains all the userspace bits.  The /etc/ service and the deamon that reports
the ecc errors to the BMC.
Comment 3 IBM Bug Proxy 2008-03-31 22:40:46 EDT
Created attachment 299809 [details]
Kernel:  IBM RTL driver

This driver interacts with a bios table in the EDBA labeled _RTL_ .  It
creates a sysfs interface for users to use to enter/exit the BIOS SMI
free state (/sys/devices/system. 

From below it is a pretty decent description of what this patch does. 

+	  Enable support for IBM Preimium Real Time Mode (PRTM). 
+	  This module will allow you the enter and exit PRTM in the BIOS via 
+	  sysfs on platforms that support this feature.  System in PRTM will 
+	  not recive cpu generated SMIs for recoverable errors.  Use of this 
+	  feature without proper support may void your hardware warranty. 
+	  
+	  If the proper bios support is found the driver will load and create
+	  /sys/devices/system/ibm_rtl/.  The "state" variable will indicate 
+	  weather or not the BIOS is in PRTM. 
+	  state = 0 (BIOS SMI's on) 
+	  state = 1 (BIOS SMI's off) 

On system that do not support the feature the module fails to load. 

This driver is written by me, and thoroughly tested on our 2 platforms
that support this feature. I would not call it hardened just well
tested. Any further platforms from IBM will use this same interface. 

This has been updated to use the readb and writeb interface from the patch on
the list. 

Signed-off-by:	Keith Mannthey<kmannth@us.ibm.com>
---
Comment 4 IBM Bug Proxy 2008-03-31 22:48:45 EDT
------- Comment From mannthey@us.ibm.com 2008-03-31 22:44 EDT-------
(From update of attachment 35807)
This is a port of the current SVN Patch "drivers-edac-new-k8-rev-f.patch"

It adds the AMD rev F (and all earlier) support to the EDAC frame work.

My LS21s I use for testing are not booting 2.6.24 kernels that I build
from the source rpm.  The binary MRG kernel is working just fine but any
other 2.6.24.3 kernel is having issues (I will be posting another email
about this issue shortly) so please take the patch as RFC only,  I am
working to get this sorted out ASAP.  We used the AMD64 driver with our
2.6.21 build so this EDAC driver has not been thoroughly tested yet.

Signed-off-by:	Keith Mannthey <kmannth@us.ibm.com>

------- Comment From mannthey@us.ibm.com 2008-03-31 22:46 EDT-------
Ok I think everthing is here Userspace bits, RTL kernel driver and the 3 EDAC
patches.

It has been tested on LS21 and HS21 with the MRG kernel as a base.

Please send me any feedback you have.
Comment 5 IBM Bug Proxy 2008-03-31 22:48:47 EDT
Created attachment 299810 [details]
EDAC refactor

This is a port of a current SVN EDAC patched called
"drivers-edac-refactor-opstate_init.patch" to current MRG. 

It is a consolidation of code related to EDAC drivers polling or waiting
for NMIs. 

The AMD driver (next patch) uses this interface. 

Signed-off-by:	Keith Mannthey <kmannth@us.ibm.com>
---
Comment 6 IBM Bug Proxy 2008-03-31 22:48:49 EDT
Created attachment 299811 [details]
AMD EDAC driver (needs the refactor patch)
Comment 7 IBM Bug Proxy 2008-03-31 22:48:50 EDT
Created attachment 299812 [details]
EDAC 5000 TMID bit fix

This is a bit of a hack to turn off a bit in the EDAC check on the i5000
controller.

In some situations the HS21XM may raise this bit and EDAC will spam the
console with error messages to the point where the local console is
unusable.  The error involves memory trying to throttle itself due to
temperature reasons.  Our BIOS folks said the feature is not supported,
that they don't trigger on that bit being set and to ignore the error.
I don't have any option but to ignore the bit at this time. 

This is has been well tested to fix the issue. 

Signed-off-by:	Keith Mannthey<kmannth@us.ibm.com>
Comment 8 IBM Bug Proxy 2008-06-10 14:25:03 EDT
------- Comment From dvhltc@us.ibm.com 2008-06-10 14:20 EDT-------
Still pending the final package from Clark,  Should become available this week.
Comment 9 Clark Williams 2008-06-10 20:10:38 EDT
ibm-prtm-1.0-1.el5rt pushed to beta repository
Comment 10 Clark Williams 2008-07-01 17:15:15 EDT
Are we good on this one?
Comment 11 Clark Williams 2008-07-02 11:27:28 EDT
Delivered with MRG 1.0 GA

Closing

Note You need to log in before you can comment on or make changes to this bug.