Bug 438485 - Module i2c-piix4 isn't built on x86_64
Module i2c-piix4 isn't built on x86_64
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-21 07:47 EDT by Dario Castellarin
Modified: 2008-04-09 01:14 EDT (History)
0 users

See Also:
Fixed In Version: 2.6.24.4-64.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-01 17:37:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sensors-detect failure (914 bytes, text/plain)
2008-03-21 07:47 EDT, Dario Castellarin
no flags Details

  None (edit)
Description Dario Castellarin 2008-03-21 07:47:26 EDT
Description of problem:
The SMBus driver i2c-piix4 isn't built in x86_64 kernels. This module is
necessary to handle ATI SMB as SB600. Running 'sensors-detect' finds the device
but cannot load the module. This seems to be the same issue as bug #424541, if
RHEL can have it, I guess that even Fedora can ;)


Version-Release number of selected component (if applicable):
kernel-2.6.24.3-34.fc8
lm_sensors-2.10.6-1.fc8



How reproducible:
Always


Steps to Reproduce:
1. run 'sensors-detect'
2. fail to load i2c-piix4
3. be sad
  
Actual results:
i2c-piix4 isn't found

Expected results:
i2c-piix4 loads fine

Additional info:
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 13)
Comment 1 Dario Castellarin 2008-03-21 07:47:26 EDT
Created attachment 298788 [details]
sensors-detect failure
Comment 2 Dave Jones 2008-03-21 11:29:09 EDT
enabled in cvs, will be in the next build.
Comment 3 Dario Castellarin 2008-03-27 07:12:19 EDT
I just tested kernel 2.6.24.4-58, the module is built and works fine. Case
closed for what regards me ;)
Comment 4 Fedora Update System 2008-03-28 16:58:19 EDT
kernel-2.6.24.4-63.fc8 has been submitted as an update for Fedora 8
Comment 5 Fedora Update System 2008-03-29 14:31:33 EDT
kernel-2.6.24.4-64.fc8 has been submitted as an update for Fedora 8
Comment 6 Fedora Update System 2008-04-01 17:37:36 EDT
kernel-2.6.24.4-64.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2008-04-09 01:14:26 EDT
kernel-2.6.24.4-64.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.