Bug 438579 - wifi interface available even when it's off
wifi interface available even when it's off
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-22 07:44 EDT by Paul Osmialowski
Modified: 2008-03-25 09:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-25 09:40:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages at the boot time with wifi switch set to off (Asus F9F) (36.66 KB, text/plain)
2008-03-24 13:49 EDT, Paul Osmialowski
no flags Details
ifconfig wlan0 and iwconfig wlan0 outputs (Wireless switch was off since reboot all the time) (719 bytes, text/plain)
2008-03-24 13:53 EDT, Paul Osmialowski
no flags Details

  None (edit)
Description Paul Osmialowski 2008-03-22 07:44:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.8.1.12) Gecko/20080208 Fedora/2.0.0.12-1.fc8 Firefox/2.0.0.12

Description of problem:
Before I've upgraded F7 to F8 on my Asus F9F notebook everything was working fine.
F9F has WiFi adapter listed by lspci as: 02:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02). I guess it uses these modules listed by lsmod:
iwl3945               156469  0
mac80211              190389  1 iwl3945
cfg80211               26441  2 iwl3945,mac80211
There's an on/off switch on F9F cover that while running Vista makes wireless network interface to switch on/off (which is indicated by Vista by popup message). On FC7 it wasn't that nice, BUT the state of the switch was checked at kernel startup (I guess at the time the module was loaded into the kernel, now I don't have FC7 on this hardware anymore so I can't even check if the module was even loaded when the switch was off). If the switch was off, wlan0 interface wasn't created, so iwconfig didn't even list it. Now on F8 it says wlan0 is up and running even if the switch was off all the time. Also green led on the F9F cover says WiFi is in use. If so I guess it uses battery power at the time I don't need WiFi, which isn't nice feature for F8. That's yet another problem I've encountered after F7 -> F8 upgrade!!!!!!


Version-Release number of selected component (if applicable):
kernel-2.6.24.3-34.fc8

How reproducible:
Always


Steps to Reproduce:
1. Install F8 on Asus F9F
2. Turn WiFi off using easy-to-find switch on F9F cover
3. Reboot Linux

Actual Results:
iwconfig says wlan0 interface is up and running. Also WiFi LED is on right at the moment kernel is started.


Expected Results:
None of actual results.


Additional info:
Comment 1 John W. Linville 2008-03-24 11:31:57 EDT
FWIW, the LED support has yet to be added to that driver (much to my chagrin).  
So whatever LED is showing is at best untrustworthy.

Please attach the contents of /var/log/messages after booting with switch set 
to disable wifi.  Please also include the output of running "ifconfig wlan0" 
and "iwconfig wlan0".  Thanks!
Comment 2 Paul Osmialowski 2008-03-24 13:49:21 EDT
Created attachment 298909 [details]
/var/log/messages at the boot time with wifi switch set to off (Asus F9F)
Comment 3 Paul Osmialowski 2008-03-24 13:53:48 EDT
Created attachment 298910 [details]
ifconfig wlan0 and iwconfig wlan0 outputs (Wireless switch was off since reboot all the time)
Comment 4 Paul Osmialowski 2008-03-24 13:55:11 EDT
> So whatever LED is showing is at best untrustworthy.
But it worked right on F7!
Comment 5 John W. Linville 2008-03-24 14:00:10 EDT
If the LED worked, I don't know how -- there has never been any LED support 
for the iwl3945 driver.  Perhaps you were using the ipw3945 driver then?
Comment 6 John W. Linville 2008-03-24 14:07:44 EDT
The attachment in comment 3 shows that the interface is down.  This should 
represent the lowest power consumption state (i.e. "off" or as close as 
possible) for the device.  Are you just bothered by the LED?

Just to verify, leave the switch in the "wireless disabled" position.  Then 
do "ifconfig wlan0 up".  What messages from iwl3945 do you get 
in /var/log/messages?  Are you able to configure the interface and get a 
connection?
Comment 7 Paul Osmialowski 2008-03-24 17:17:57 EDT
> Perhaps you were using the ipw3945 driver then?
Rather not. I don't remember now what module was used in F7, but as I see,
ipw3945 is a part of ATrpms repository while I'm using Fedora distribution drivers.

> Just to verify, leave the switch in the "wireless disabled" position.  Then 
do "ifconfig wlan0 up".  What messages from iwl3945 do you get 
in /var/log/messages?  Are you able to configure the interface and get a 
connection?

[root@twink ~]# LC_ALL=en_GB ifconfig wlan0 up
SIOCSIFFLAGS: No such device

After that two most bottom lines of dmesgs says:
ACPI: PCI Interrupt 0000:02:00.0[A] -> GSI 17 (level, low) -> IRQ 17
iwl3945: Radio disabled by HW RF Kill switch

You're right, it can read the switch. I was worried by the LED and the presence
of wlan0 interface.

Is it possible that on F7 somehow the switch state was checked before the module
was actually loaded, so the lack of LED-related code inside of the driver wasn't
playing a role in this?

Comment 8 Paul Osmialowski 2008-03-24 17:20:48 EDT
I've forgotten to mention! The same goest to bluetooth LED. Now it is on all the
time although I didn't configure bluetooth device on F8 neither on F7. It wasn't
like that on F7.
Comment 9 John W. Linville 2008-03-25 09:40:24 EDT
It is a bit complicated, but previous versions of the driver did things a bit 
differently.  They loaded device firmware when the driver was loaded, but 
didn't actually register the network interface if the rfkill switch is on.  
Now they register the interface, but don't load the firmware unless the 
interface is marked up.  There are various reasons why this seemed preferable, 
but one downside is that rfkill status can't be detected while the interface 
is marked down (because the firmware actually does the detection).

I have no explanation for the LED issue.  Possible things that might have 
changed would be a BIOS update or a change in some other part of the kernel 
(e.g. the ACPI interpreter) that changed the default LED state -- no idea 
really.  FWIW, bug 251847 already exists for the issue where the driver does 
not control the LEDs.  Feel free to monitor that for future changes.

Note You need to log in before you can comment on or make changes to this bug.