Bug 438615 - gpsd cannot be found in gpsdrive
gpsd cannot be found in gpsdrive
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gpsdrive (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-22 18:40 EDT by michael roberts
Modified: 2008-09-10 03:08 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.09-5.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-06 15:38:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description michael roberts 2008-03-22 18:40:24 EDT
/Description of problem:
when you boot gpsdrive
i cannot find my gps in gpsdrive  i opened the rpm for gpsd and found that gpsd
is in sbin and not bin

gpsd cannot be found in /usr/bin/
it is in /usr/sbin/

version


Steps to Reproduce:
1.boot up gpsdrive in terminal
2. start it  and it will not  find the gps
3.if you enter the command  "cp /usr/sbin/gpsd  /usr/bin/" then retry  it will
find the gps  and work normaly 
Actual results:


Expected results:


Additional info: could somebody fix the gpsd rpm in an update from where the rpm
will write to gpsd and load into /usr/bin/ and not /usr/sbin/
Comment 1 michael roberts 2008-03-22 18:46:48 EDT
i left out version gpsd 2.34
 
gpsdrive  1.525 
Comment 2 michael roberts 2008-03-22 20:17:54 EDT
i left out version gpsd 2.34
 
gpsdrive  1.525 
Comment 3 Douglas E. Warner 2008-03-24 14:20:24 EDT
Reassigning to gpsdrive component.

gpsd is installed in its upstream location.  gpsdrive looks in the wrong 
location due to its bundling of gpsd.  gpsd is now an active project and 
should no longer be bundled with gpsdrive; gpsdrive should respect gpsd's 
installation location and handle it in its configure script.
Comment 4 Kevin Fenzi 2008-03-24 15:33:00 EDT
Version 1.525? Where did you get this version? 
gpsdrive in fedora is version 2.09. 

What is the output of 'rpm -q gpsdrive' and 'gpsdrive -v' ?

gspdrive in fedora looks in the right place and doesn't ship it's own gpsd. 

However, I did just spot an issue with how it calls gpsd... it tries to pass 
a '-p' argument to it. I will get that fixed up. However, that doesn't seem to
be what the orig poster is reporting. 
Comment 5 Kevin Fenzi 2008-04-08 23:28:52 EDT
ok, I found time to look further into this... 

gpsdrive calls gpsd with 'gpsd', ie, no path at all, so if /usr/sbin/ is in your
path it would call the right thing. However, it calls it with all sorts of
incorrect arguments, so I have no idea how it worked for the orig poster. 

Then, if gpsd was started by hotplug (ie, it's a usb device), gpsdrive can't
kill or start it, which is ok I guess. 

In any case I patched things up as best I could.
There should be an update out before too long. 

You are welcome to also grab the package from the buildsystem and try it out: 
http://koji.fedoraproject.org/koji/taskinfo?taskID=558911




Comment 6 Fedora Update System 2008-04-08 23:30:30 EDT
gpsdrive-2.09-5.fc8 has been submitted as an update for Fedora 8
Comment 7 Fedora Update System 2008-04-08 23:39:07 EDT
gpsdrive-2.09-5.fc7 has been submitted as an update for Fedora 7
Comment 8 michael roberts 2008-04-09 21:59:19 EDT
sorry i coulnt reply  but i am glad this issue is resolved and thank you for
helping me
Comment 9 michael roberts 2008-04-09 22:15:30 EDT
what i don't understand is why /usr/sbin and not /usr/bin 

is it because it is a deamon, because in Debian or other Linux os they have it
from where you can access the bin from a command prompt
Comment 10 Kevin Fenzi 2008-04-09 23:19:52 EDT
Well, in the past, gpsd would be a command that only the root user would run, as
regular users wouldn't have the ability to read/write to serial devices. 
Since we now can allow local users to do that it's not as important. 

In any case, hopefully the fix will work for you. ;) 
Comment 11 Fedora Update System 2008-04-16 23:48:58 EDT
gpsdrive-2.09-5.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gpsdrive'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F7/FEDORA-2008-3062
Comment 12 Fedora Update System 2008-06-06 03:45:50 EDT
gpsdrive-2.09-5.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2008-06-06 03:48:44 EDT
gpsdrive-2.09-5.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Kevin Fenzi 2008-06-06 15:38:42 EDT
This update has been pushed out, I'm going to go ahead and close this now. 
Feel free to re-open or file a new bug if you spot anything further. 

Comment 15 Fedora Update System 2008-08-28 00:13:10 EDT
gpsdrive-2.09-6.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/gpsdrive-2.09-6.fc9
Comment 16 Fedora Update System 2008-09-10 03:08:51 EDT
gpsdrive-2.09-6.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.