Bug 438618 - ircd install fails to create ircd user
ircd install fails to create ircd user
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ircd-hybrid (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Eric Tanguy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-22 20:45 EDT by JW
Modified: 2008-04-22 18:35 EDT (History)
0 users

See Also:
Fixed In Version: 7.2.3-5.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-22 18:35:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description JW 2008-03-22 20:45:02 EDT
Description of problem:
During installation of ircd-hybrid rpm script fails to create ircd user

Version-Release number of selected component (if applicable):
ircd-hybrid-7.2.3-2

How reproducible:
Always

Steps to Reproduce:
1. rpm -vi ircd-hybrid-7.2.3-2.fc8.i386.rpm
  
Actual results:
No ircd user created in /etc/passwd

Expected results:
ircd user should be created

Additional info:
Unfortunately the useradd code in %pre script has stderr redirected to /dev/null
so useful error messages are not seen (why would anyone redirect stderr to
/dev/null?).  Perhaps it is because of the "fedora-useradd 14 -s ..." where the
14 is probably a syntax error?  This is an old bug that has been around since fc4.
Comment 1 Fedora Update System 2008-03-24 12:40:30 EDT
ircd-hybrid-7.2.3-5.fc8 has been submitted as an update for Fedora 8
Comment 2 Fedora Update System 2008-03-26 13:12:11 EDT
ircd-hybrid-7.2.3-5.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ircd-hybrid'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-2680
Comment 3 Fedora Update System 2008-04-22 18:35:32 EDT
ircd-hybrid-7.2.3-5.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.