This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 43862 - RPM 4.0.3-0.6.6x commands fail to work on Solaris 2.8
RPM 4.0.3-0.6.6x commands fail to work on Solaris 2.8
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.0
sparc64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-07 13:46 EDT by Need Real Name
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-07 13:46:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-06-07 13:46:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.7 [en] (X11; U; SunOS 5.8 sun4u)

Description of problem:
I downloaded rpm-4.0.3-0.6.6c-src.rpm, got the source files and tried
to compile from scratch on my Solaris 2.8 machine using gcc. It compiled
successfully, however, when I tried to do those simple tasks like:

 rpm -i <packagename>
 rpm -qa <packagename>
 rpm -e <packagename>

I got error message:

 Illegal Instruction

The only thing thast seems to work is command "rpm -qpil <packagename>"

How reproducible:
Always

Steps to Reproduce:
1.rpm -i wget-1.6-1.rpm
2.
3.
	

Actual Results:  Illegal Instruction


Expected Results:  package wget-1.6-1 is installed

Additional info:
Comment 1 Jeff Johnson 2001-08-04 14:44:58 EDT
I have no way of reproducing this problem, but have several reports
of success building rpm-4.0.3 on Solaris. So, I'm gonna close
this bug. I'd check your build system ...

Note You need to log in before you can comment on or make changes to this bug.