Bug 438632 - kdebase4 missing dependency on kdebase-runtime and oxygen-icon-theme (causes missing icons in Dolphin)
kdebase4 missing dependency on kdebase-runtime and oxygen-icon-theme (causes ...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-23 11:57 EDT by Dean Mander
Modified: 2010-12-07 13:41 EST (History)
9 users (show)

See Also:
Fixed In Version: 4.0.3-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-10 07:56:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
std error output from dolphin (16.74 KB, text/plain)
2008-03-23 11:57 EDT, Dean Mander
no flags Details
output from standard error (18.47 KB, application/octet-stream)
2008-03-23 12:03 EDT, Dean Mander
no flags Details

  None (edit)
Description Dean Mander 2008-03-23 11:57:07 EDT
Description of problem:
d3lphin has been replaced by package kdebase4 since a yum update a few days ago.

However, the dolphin delivered with this package doesn't work:

- can't find any of its icons
- takes > 1 minute to load (d3lphin took 3 seconds)
- lots of other errors (see attachment)

Version-Release number of selected component (if applicable):
kdebase4-4.0.1-3.fc8.i386

How reproducible:
always

Steps to Reproduce:
1. have d3lphin installed (impossible after latest updates)
2. yum update
Comment 1 Dean Mander 2008-03-23 11:57:07 EDT
Created attachment 298865 [details]
std error output from dolphin
Comment 2 Dean Mander 2008-03-23 12:03:59 EDT
Created attachment 298866 [details]
output from standard error
Comment 3 Dean Mander 2008-03-23 12:04:57 EDT
kdebase4 - 4.0.2-2.fc8.i386 doesn't fix the problem ;
though the error message changes (see second attachment).


Comment 4 Kevin Kofler 2008-03-23 14:09:26 EDT
yum install kdebase-runtime
(Yes, the dependency is missing, and yes, we will add it.)
Comment 5 Dean Mander 2008-03-24 09:47:31 EDT
does the job :)
Thanks for your swift reply.


Comment 6 Kevin Kofler 2008-03-24 10:53:42 EDT
Please keep this open until we add the dependency, it should not be necessary 
to install kdebase-runtime by hand to get Dolphin fully functional.
Comment 7 Kevin Kofler 2008-03-24 10:55:11 EDT
(Both the Oxygen icons and the main part of kdebase-runtime (ioslaves in 
particular) are needed.)
Comment 8 Kevin Kofler 2008-03-28 18:46:37 EDT
I've added these dependencies in kdebase-4.0.3-2.fc9, so F7 and F8 will get 
them when we build 4.0.3 for them.

Note You need to log in before you can comment on or make changes to this bug.