Bug 438693 - [RHEL5 U2]Firefox does not stay on proper desktop
[RHEL5 U2]Firefox does not stay on proper desktop
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: metacity (Show other bugs)
5.2
All Linux
high Severity medium
: rc
: ---
Assigned To: Christopher Aillon
desktop-bugs@redhat.com
: Regression
: 439156 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-24 11:00 EDT by Jeff Burke
Modified: 2008-05-21 10:26 EDT (History)
5 users (show)

See Also:
Fixed In Version: RHBA-2008-0484
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 10:26:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Burke 2008-03-24 11:00:09 EDT
Description of problem:
 Running in gnome environment. I have several desktops. If I open firefox on
desktop 2 and then in desktop 1 I click a web url, firefox moves to desktop 1.
Prior to upgrading to RHEL5.2 Beta it would remain on desktop 2.

Version-Release number of selected component (if applicable):
 firefox-3.0-0.beta4.1.el5
 xulrunner-1.9-0.beta4.1.el5

How reproducible:
 Always


Expected results:
 Firefox should remain on the desktop I selected

Additional info:

I was told that this is a "known issue with a known patch" and 
that we had included for the beta.

The version I am using is the version that should have the fix.

"The fix is basically stop building the broken stuff. We have the right
--disable flag set"
Comment 1 RHEL Product and Program Management 2008-03-24 12:03:10 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 2 Richard Monk 2008-03-28 06:59:01 EDT
*** Bug 439156 has been marked as a duplicate of this bug. ***
Comment 3 Colin Walters 2008-03-31 10:13:37 EDT
This is a duplicate of this Fedora bug:
https://bugzilla.redhat.com/show_bug.cgi?id=307581
Which is itself now forwarded to upstream Metacity:
http://bugzilla.gnome.org/show_bug.cgi?id=482354
Comment 4 Colin Walters 2008-03-31 10:36:00 EDT
The correct fix for this issue is not to disable startup-notification support in
firefox, but instead to pull in the relevant Metacity patch from rawhide.
Comment 14 errata-xmlrpc 2008-05-21 10:26:53 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0484.html

Note You need to log in before you can comment on or make changes to this bug.