Bug 438738 - Unable to connect to https url with TLS 1.0
Unable to connect to https url with TLS 1.0
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution-exchange (Show other bugs)
rawhide
All Linux
low Severity urgent
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-24 15:29 EDT by Russell Harrison
Modified: 2008-04-28 11:00 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-28 11:00:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 527633 None None None Never

  None (edit)
Description Russell Harrison 2008-03-24 15:29:55 EDT
Description of problem:
When I attempt to setup a MS Exchange account in evolution for rawhide I get a
error dialog asking me to check the URL again.

Version-Release number of selected component (if applicable):
(evolution:13880): e-data-server-ui-WARNING **: Unable to find password(s) in
keyring (Keyring reports: No matching results)

How reproducible:
Every time

Steps to Reproduce:
1. Install evolution and evolution-exchange in rawhide
2. Attempt to setup an exchange account
3. On the Receiving Email screen click on the authenticate button to continue
setting up the account.
  
Actual results:
A dialog box pops up:
Could not connect to server.
Make sure the URL is correct and try again.

Expected results:
Evolution authenticates with the exchange server and continues the setup process.

Additional info:
I ran evolution with the E2K_DEBUG variable all the way to 5.  When I reproduce
the above problem I get the following error:

(evolution:13880): e-data-server-ui-WARNING **: Unable to find password(s) in
keyring (Keyring reports: No matching results)
Comment 1 Matthew Barnes 2008-03-24 16:10:09 EDT
Are you able to get to Outlook Web Access using the same URL you've given to
Evolution?  What type of authentication have you selected?  Do any of the other
authentication types work?
Comment 2 Russell Harrison 2008-04-14 12:56:23 EDT
I think we've narrowed down the problem a bit on our side.  It seems to be
related to our SSL offloading apliance only supporting TLS1.0.  Evolution 2.22
tries to use TLS1.1 and fails instead of dropping back to TLS1.0.  Ether the
Exchange connector needs to be able to fall back to TLS1.0 automatically or
there needs to be an option to specify TLS1.0 when using a https://... url.

http://bugzilla.gnome.org/show_bug.cgi?id=527633
Comment 3 Russell Harrison 2008-04-26 10:28:36 EDT
Is there any way to tell Evolution to use TLS1.0 instead?
Comment 4 Matthew Barnes 2008-04-28 11:00:03 EDT
Moving this upstream.  I'll continue monitoring the other bug you filed.

Note You need to log in before you can comment on or make changes to this bug.