Bug 438823 - Bind examples of the deployment guide misses the newlines
Bind examples of the deployment guide misses the newlines
Status: CLOSED DUPLICATE of bug 453071
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Deployment_Guide (Show other bugs)
5.1
All Linux
low Severity low
: rc
: ---
Assigned To: Murray McAllister
Content Services Development
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-25 10:08 EDT by Stefano Cavallari
Modified: 2016-06-17 17:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-03 14:30:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefano Cavallari 2008-03-25 10:08:36 EDT
Description of problem:
In the "Bind" chapter (17), in Section 3.3 and 3.4 the examples misses the newlines.
See
http://www.redhat.com/docs/manuals/enterprise/RHEL-5-manual/en-US/RHEL510/Deployment_Guide/s2-bind-zone-examples.html
http://www.redhat.com/docs/manuals/enterprise/RHEL-5-manual/en-US/RHEL510/Deployment_Guide/s2-bind-configuration-zone-reverse.html


Version-Release number of selected component (if applicable):
Oct 31, 2007
Comment 1 Murray McAllister 2008-07-10 01:35:17 EDT
I have these fixed offline, but the configuration files are wrong and named will
not start if you use them.

I will be fixing these soon.

Cheers,

Murray.
Comment 2 Murray McAllister 2008-07-13 05:29:56 EDT
r8190 | mmcallis@REDHAT.COM | 2008-07-13 19:29:12 +1000 (Sun, 13 Jul 2008) | 8 lines

17.3.2. Zone File Resource Records
- changing "an SOA" to "a SOA".
- fix missing line breaks in configuration files.
- s/PoinTer/pointer.
- small mention that DNS round robin does not work
if there is no space in the host section of the next
record.
Comment 3 Murray McAllister 2008-07-13 06:09:54 EDT
For "17.3.3. Example Zone File":

r8191 | mmcallis@REDHAT.COM | 2008-07-13 20:08:11 +1000 (Sun, 13 Jul 2008) | 4 lines

- zone files need ";" for blank lines.
- zone file example had a ")" in the wrong place.
- there are a few issues, see Red Hat BZ# 455162
Comment 4 Murray McAllister 2008-07-13 19:15:10 EDT
r8194 | mmcallis@REDHAT.COM | 2008-07-14 09:14:12 +1000 (Mon, 14 Jul 2008) | 16
lines

Red Hat BZ# 438823

17.3.2. Zone File Resource Records
- reverting change to "a SOA" (now "an SOA").

17.3.4. Reverse Name Resolution Zone Files:
- configuration had ")" in the wrong location.
- added ";" for empty lines in configuration (required).
- fixing line breaks.

17.4.1. Configuring /etc/named.conf
- fixing line breaks.

17.4.2. Configuring /etc/rndc.conf
- fixing line breaks.
Comment 5 Murray McAllister 2008-07-13 19:15:54 EDT
Changes are in and will be picked up during the next release cycle.

Thanks,

Murray.
Comment 6 Douglas Silas 2009-09-03 14:30:20 EDT
Fixed in bug 453071.

*** This bug has been marked as a duplicate of bug 453071 ***

Note You need to log in before you can comment on or make changes to this bug.