Bug 438862 - Haartrainer fails with error consistently
Haartrainer fails with error consistently
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: opencv (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Ralf Corsepius
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-25 13:26 EDT by Trever Adams
Modified: 2008-04-27 17:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-27 17:52:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Trever Adams 2008-03-25 13:26:24 EDT
Description of problem:

When I try to use haartraining for my own face database, I get the following
errors. It happens even when I start the process from scratch and not
continuing. I get a similar error when doing some other data sets. I don't know
enough about this library to debug it further.


opencv-haartraining -data trainout -vec $SName.vec -bg $SName.neg -nstages 20
-nsplits 5 -minhitrate 0.999 -maxfalsealarm 0.5 -npos `cat $SName.dat | wc -l`
-nneg `cat $SName.neg | wc -l` -w $Size -h $Size -mem 600 -mode ALL -minpos `cat
$SName.dat | wc -l | awk '{if ($1<100) print $1/2; else if ($1 < 250) print
$1/3; else if ($1<400) print $1/4; else if ($1 > 500) print $1/5; else if ($1 >
2500) print 500 }'`

Info file name: Human.Face.dat
Img file name: (NULL)
Vec file name: Human.Face.vec
BG  file name: Human.Face.neg
Num: 910
BG color: 0
BG threshold: 80
Invert: FALSE
Max intensity deviation: 40
Max x angle: 1.1
Max y angle: 1.1
Max z angle: 0.5
Show samples: FALSE
Width: 32
Height: 32
Create training samples from images collection...
Done. Created 910 samples
Data dir name: trainout
Vec file name: Human.Face.vec
BG  file name: Human.Face.neg
Num pos: 910
Num neg: 3431
Num stages: 20
Num splits: 5 (tree as weak classifier)
Mem: 600 MB
Symmetric: TRUE
Min hit rate: 0.999000
Max false alarm rate: 0.500000
Weight trimming: 0.950000
Equal weights: FALSE
Mode: ALL
Width: 32
Height: 32
Max num of precalculated features: 24155
Applied boosting algorithm: GAB
Error (valid only for Discrete and Real AdaBoost): misclass
Max number of splits in tree cascade: 5
Min number of positive samples per cluster: 182
Required leaf false alarm rate: 1.58946e-07
Stage 0 loaded
Stage 1 loaded
Stage 2 loaded
Stage 3 loaded
Stage 4 loaded
Stage 5 loaded
Stage 6 loaded
Stage 7 loaded
Stage 8 loaded
Stage 9 loaded
Stage 10 loaded
Stage 11 loaded
Stage 12 loaded
Stage 13 loaded
Stage 14 loaded

....




Parent node: 14

*** 1 cluster ***
POS: 639 910 0.702198
NEG: 2409 0.031895
BACKGROUND PROCESSING TIME: 1.00
Precalculation time: 36.00
+----+----+-+---------+---------+---------+---------+
|  N |%SMP|F|  ST.THR |    HR   |    FA   | EXP. ERR|
+----+----+-+---------+---------+---------+---------+
|   1|100%|-|-0.809414| 1.000000| 1.000000| 0.079068|
+----+----+-+---------+---------+---------+---------+
|   2|100%|+|-1.054166| 1.000000| 1.000000| 0.197835|
+----+----+-+---------+---------+---------+---------+
|   3| 98%|-|-1.162886| 1.000000| 0.949357| 0.127953|
+----+----+-+---------+---------+---------+---------+
|   4| 95%|+|-1.097617| 1.000000| 0.943130| 0.131234|
+----+----+-+---------+---------+---------+---------+
|   5| 94%|-|-1.099095| 1.000000| 0.889581| 0.114829|
+----+----+-+---------+---------+---------+---------+
|   6| 89%|+|-1.050487| 1.000000| 0.873391| 0.105971|
+----+----+-+---------+---------+---------+---------+
|   7| 88%|-|-1.067521| 1.000000| 0.865919| 0.102362|
+----+----+-+---------+---------+---------+---------+
|   8| 87%|+|-1.070924| 1.000000| 0.860108| 0.103018|
+----+----+-+---------+---------+---------+---------+
|   9| 87%|-|-1.023676| 1.000000| 0.811125| 0.093176|
+----+----+-+---------+---------+---------+---------+
|  10| 83%|+|-1.186890| 1.000000| 0.803653| 0.092192|
+----+----+-+---------+---------+---------+---------+
OpenCV ERROR: Bad flag (parameter or structure field) ()
        in function cvReleaseMat, cxarray.cpp(234)
Terminating the application...
        called from cvUnregisterType, cxpersistence.cpp(4933)
Terminating the application...
        called from cvUnregisterType, cxpersistence.cpp(4933)
Terminating the application...
        called from cvUnregisterType, cxpersistence.cpp(4933)
Terminating the application...
        called from cvUnregisterType, cxpersistence.cpp(4933)
Terminating the application...
        called from cvUnregisterType, cxpersistence.cpp(4933)
Terminating the application...
        called from cvUnregisterType, cxpersistence.cpp(4933)
Terminating the application...
        called from cvUnregisterType, cxpersistence.cpp(4933)
Terminating the application...
        called from cvUnregisterType, cxpersistence.cpp(4933)
Terminating the application...
        called from cvUnregisterType, cxpersistence.cpp(4933)
Terminating the application...


Version-Release number of selected component (if applicable):
opencv-1.0.0-3.fc8

How reproducible:
Every time with this data set (about 20 times now) occassionally with other data
sets.

Steps to Reproduce:
Without sharing my data sets, which I cannot do, I am not sure. (size being one
reason)
Comment 1 Trever Adams 2008-03-30 13:47:45 EDT
This happens with even i386. All architectures affected?
Comment 2 Trever Adams 2008-04-27 17:52:26 EDT
This is caused, in my case, by the trainer giving bad results because it cannot
learn ALL the positive images to the satisfaction of the configuration fed to
it. (Lower your necessary positive number and things will work fine.) Very poor
error messages.

Note You need to log in before you can comment on or make changes to this bug.