Bug 438881 - [RHEL5 U2] Firefox ASSERT when managing bookmarks
[RHEL5 U2] Firefox ASSERT when managing bookmarks
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: firefox (Show other bugs)
5.2
All Linux
low Severity medium
: rc
: ---
Assigned To: Christopher Aillon
desktop-bugs@redhat.com
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-25 14:38 EDT by Jeff Burke
Modified: 2009-09-08 14:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-08 14:41:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Burke 2008-03-25 14:38:18 EDT
Description of problem:

 ASSERT: null node
 Stack Trace: 
 0:PU_nodeIsContainer(undefined)
 1:PTV_isContainer(16)

Version-Release number of selected component (if applicable):

 Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5pre) Gecko/2008030509 Red
Hat/3.0b5pre-0.beta4.1.el5 Minefield/3.0b5pre

How reproducible:
 Always

Steps to Reproduce:
1. Open Firefox, Add several valid bookmarks
2. BookMarks -> Show All Bookmarks -> double click "Bookmarks Menu"
3. Move the last bookmark above the top one
  
Actual results:
ASSERT: null node
Stack Trace: 
0:PU_nodeIsContainer(undefined)
1:PTV_isContainer(16)

ASSERT: null node
Stack Trace: 
0:PU_nodeIsSeparator(undefined)
1:PTV_isSeparator(16)

ASSERT: null node
Stack Trace: 
0:PU_nodeIsContainer(undefined)
1:PTV_isContainer(16)

ASSERT: null node
Stack Trace: 
0:PU_nodeIsContainer(undefined)
1:PTV_isContainer(16)

ASSERT: null node
Stack Trace: 
0:PU_nodeIsSeparator(undefined)
1:PTV_getImageSrc(16,[object TreeColumn])

ASSERT: null node
Stack Trace: 
0:PU_nodeIsContainer(undefined)
1:PTV_isContainer(16)

ASSERT: null node
Stack Trace: 
0:PU_nodeIsContainer(undefined)
1:PTV_isContainer(16)

ASSERT: null node
Stack Trace: 
0:PU_nodeIsURI(undefined)
1:PTV_getCellText(16,[object TreeColumn])

Expected results:
This function should work without error

Additional info:
BookMarks -> Show All Bookmarks -> Right click on "Bookmarks Menu" select
properties. NOTE: the windows says "Properties for "(null)"
Comment 3 RHEL Product and Program Management 2008-04-10 13:43:47 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 6 RHEL Product and Program Management 2009-01-27 15:42:26 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 8 Jeff Burke 2009-09-08 14:41:32 EDT
I no longer see this issue with Red Hat Enterprise Linux Server 5 update 4.

Firefox Version 3.0.12. Red Hat/3.0.12-1-el5_3

Note You need to log in before you can comment on or make changes to this bug.