Bug 438963 - crash when jigdo-downloading F9-Beta iso image
crash when jigdo-downloading F9-Beta iso image
Status: CLOSED DUPLICATE of bug 433606
Product: Fedora
Classification: Fedora
Component: wget (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Karsten Hopp
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-26 04:30 EDT by Matěj Cepl
Modified: 2008-03-26 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-26 12:32:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matěj Cepl 2008-03-26 04:30:36 EDT
Description of problem:
When running jigdo for installation of F-9 Beta iso image jigdo crashed with
1115 corefiles. This is the backtrace:

Core was generated by `wget --user-agent=jigdo-lite/0.7.3 (GNU Wget 1.11 (Red
Hat modified); linux-gnu'.
Program terminated with signal 6, Aborted.
[New process 8806]
#0  0x0000003202432f75 in raise (sig=<value optimized out>)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
64        return INLINE_SYSCALL (tgkill, 3, pid, selftid, sig);
(gdb) bt
#0  0x0000003202432f75 in raise (sig=<value optimized out>)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#1  0x0000003202434ae3 in abort () at abort.c:88
#2  0x000000320242bf09 in __assert_fail (assertion=<value optimized out>, 
    file=<value optimized out>, line=<value optimized out>, 
    function=<value optimized out>) at assert.c:78
#3  0x000000000041d73c in create_image (bp=0x124fbd0, 
    dl_total_time=3.1293589920000002, done=false) at progress.c:972
#4  0x000000000041d8df in bar_update (progress=0x124fbd0, 
    howmuch=<value optimized out>, dltime=3.1293589920000002) at progress.c:634
#5  0x0000000000421019 in fd_read_body (fd=5, out=0x124fde0, toread=12955860, 
    startpos=<value optimized out>, qtyread=0x7ffff35a1ae8, 
    qtywritten=0x7ffff35a1aa0, elapsed=0x7ffff35a1af0, flags=1) at retr.c:311
#6  0x0000000000416754 in gethttp (u=0x1249bb0, hs=0x320276c950, 
    dt=0x7ffff35a1d78, proxy=0x0) at http.c:2281
#7  0x000000000041704c in http_loop (u=0x1249bb0, newloc=0x7ffff35a1cd8, 
    local_file=0x7ffff35a1cd0, referer=0x124a160 "��$\001", dt=0x7ffff35a1d78, 
    proxy=0x0) at http.c:2447
#8  0x00000000004206cd in retrieve_url (
    origurl=0x1249e20
"http://download.fedoraproject.org/pub/fedora/linux/releases/test/9-Beta/Fedora/i386/os/Packages/openoffice.org-langpack-xh_ZA-2.4.0-10.1.fc9.i386.rpm",
file=0x7ffff35a1d58, newloc=0x7ffff35a1d60, refurl=0x0, 
    dt=0x7ffff35a1d78, recursive=false) at retr.c:675
#9  0x000000000041eb9b in retrieve_tree (
    start_url=0x1249680
"http://download.fedoraproject.org/pub/fedora/linux/releases/test/9-Beta/Fedora/i386/os/Packages/openoffice.org-langpack-xh_ZA-2.4.0-10.1.fc9.i386.rpm")
at recur.c:252
#10 0x000000000041bebd in main (argc=19, argv=0x7ffff35a2058) at main.c:995
(gdb) 


Version-Release number of selected component (if applicable):
jigdo-0.7.3-6.fc9.x86_64
wget-1.11-2.fc9.x86_64


How reproducible:
Tried once, happened once :-) Will try again

Steps to Reproduce:
1.jigdo-lite --scan . --noask Fedora-9-Beta-i386-DVD.jigdo
2.
3.
  
Actual results:
jigdo works, downloads many rpms, but somewhere during the work (I don't know
when exactly because jigdo was running in screen on my office computer) it
begins to crash.

Expected results:
all rpms downloaded
Comment 1 Matěj Cepl 2008-03-26 06:08:37 EDT
This is stdout:

[matej@hubmaier Fedora-Unity]$ jigdo-lite --scan . --noask
Fedora-9-Beta-i386-DVD.jigdo 

Jigsaw Download "lite"
Copyright (C) 2001-2005  |  jigdo@
Richard Atterer          |  atterer.net
Loading settings from `/home/matej/.jigdo-lite'

-----------------------------------------------------------------
Images offered by `Fedora-9-Beta-i386-DVD.jigdo':
  1: Fedora-9-Beta-i386-DVD.iso

-----------------------------------------------------------------
The temporary directory `Fedora-9-Beta-i386-DVD.iso.tmpdir' already exists. Its
contents
ARE GOING TO BE DELETED (possibly after having been copied to the
image, if they are of interest for it). If you do not want this
to happen, press Ctrl-C now. Otherwise, press Return to proceed.
: 
Path to scan: .

Not downloading .template file - `Fedora-9-Beta-i386-DVD.template' already present
Error while reading `./jigdo-file-cache.db' - file will be ignored (Úspěch)
Found 0 of the 157 files required by the template                              
Copied input files to temporary file `Fedora-9-Beta-i386-DVD.iso.tmp' - repeat
command and supply more files to continue
Found 0 of the 157 files required by the template                              
Copied input files to temporary file `Fedora-9-Beta-i386-DVD.iso.tmp' - repeat
command and supply more files to continue

-----------------------------------------------------------------
Merging parts from `file:' URIs, if any...
Found 0 of the 157 files required by the template
Copied input files to temporary file `Fedora-9-Beta-i386-DVD.iso.tmp' - repeat
command and supply more files to continue
--2008-03-26 11:07:18-- 
http://download.fedoraproject.org/pub/fedora/linux/releases/test/9-Beta/Fedora/i386/os/Packages/cjkunifonts-uming-0.1.20060928-4.fc8.noarch.rpm
Překládám download.fedoraproject.org… 209.132.176.120
Navazuje se spojení s download.fedoraproject.org|209.132.176.120|:80… spojeno.
HTTP požadavek odeslán, program čeká na odpověď… 307 Temporary Redirect
Přesměrováno na:
http://mirrors.fedoraproject.org/mirrorlist?path=pub/fedora/linux/releases/test/9-Beta/Fedora/i386/os/Packages/cjkunifonts-uming-0.1.20060928-4.fc8.noarch.rpm&redirect=1
[následuji]
--2008-03-26 11:07:19-- 
http://mirrors.fedoraproject.org/mirrorlist?path=pub/fedora/linux/releases/test/9-Beta/Fedora/i386/os/Packages/cjkunifonts-uming-0.1.20060928-4.fc8.noarch.rpm&redirect=1
Překládám mirrors.fedoraproject.org… 209.132.176.122, 66.35.62.162
Navazuje se spojení s mirrors.fedoraproject.org|209.132.176.122|:80… spojeno.
HTTP požadavek odeslán, program čeká na odpověď… 302 Found
Přesměrováno na:
http://ftp.linux.cz/pub/linux/fedora/linux/releases/test/9-Beta/Fedora/i386/os/Packages/cjkunifonts-uming-0.1.20060928-4.fc8.noarch.rpm
[následuji]
--2008-03-26 11:07:20-- 
http://ftp.linux.cz/pub/linux/fedora/linux/releases/test/9-Beta/Fedora/i386/os/Packages/cjkunifonts-uming-0.1.20060928-4.fc8.noarch.rpm
Překládám ftp.linux.cz… 147.251.48.205
Navazuje se spojení s ftp.linux.cz|147.251.48.205|:80… spojeno.
HTTP požadavek odeslán, program čeká na odpověď… 200 OK
Délka: 11877059 (11M) [application/x-rpm]
Ukládám do:
„Fedora-9-Beta-i386-DVD.iso.tmpdir/ftp.linux.cz/pub/linux/fedora/linux/releases/test/9-Beta/Fedora/i386/os/Packages/cjkunifonts-uming-0.1.20060928-4.fc8.noarch.rpm“.

 2% [>                                       ] 309 565     106K/s            
wget: progress.c:972: create_image: Předpoklad „p - bp->buffer <= bp->width“
nesplněn.
/usr/bin/jigdo-lite: line 66: 10147 Neúspěšně ukončen (SIGABRT)        (core
dumped) wget --user-agent="$userAgent" $wgetOpts "$@"
Found 0 of the 157 files required by the template                              
Copied input files to temporary file `Fedora-9-Beta-i386-DVD.iso.tmp' - repeat
command and supply more files to continue
--2008-03-26 11:07:24-- 
http://download.fedoraproject.org/pub/fedora/linux/releases/test/9-Beta/Fedora/i386/os/Packages/evolution-2.22.0-1.fc9.i386.rpm
Překládám download.fedoraproject.org… 209.132.176.120
Navazuje se spojení s download.fedoraproject.org|209.132.176.120|:80… spojeno.
HTTP požadavek odeslán, program čeká na odpověď… 307 Temporary Redirect
Přesměrováno na:
http://mirrors.fedoraproject.org/mirrorlist?path=pub/fedora/linux/releases/test/9-Beta/Fedora/i386/os/Packages/evolution-2.22.0-1.fc9.i386.rpm&redirect=1
[následuji]
--2008-03-26 11:07:26-- 
http://mirrors.fedoraproject.org/mirrorlist?path=pub/fedora/linux/releases/test/9-Beta/Fedora/i386/os/Packages/evolution-2.22.0-1.fc9.i386.rpm&redirect=1
Překládám mirrors.fedoraproject.org… 209.132.176.122, 66.35.62.162
Navazuje se spojení s mirrors.fedoraproject.org|209.132.176.122|:80… spojeno.
HTTP požadavek odeslán, program čeká na odpověď… 302 Found
Přesměrováno na:
http://ultra.linux.cz/MIRRORS/fedora.redhat.com/linux/releases/test/9-Beta/Fedora/i386/os/Packages/evolution-2.22.0-1.fc9.i386.rpm
[následuji]
--2008-03-26 11:07:27-- 
http://ultra.linux.cz/MIRRORS/fedora.redhat.com/linux/releases/test/9-Beta/Fedora/i386/os/Packages/evolution-2.22.0-1.fc9.i386.rpm
Překládám ultra.linux.cz… 195.113.15.27
Navazuje se spojení s ultra.linux.cz|195.113.15.27|:80… spojeno.
HTTP požadavek odeslán, program čeká na odpověď… 200 OK
Délka: 13046367 (12M) [application/x-rpm]
Ukládám do:
„Fedora-9-Beta-i386-DVD.iso.tmpdir/ultra.linux.cz/MIRRORS/fedora.redhat.com/linux/releases/test/9-Beta/Fedora/i386/os/Packages/evolution-2.22.0-1.fc9.i386.rpm“.

 1% [                                        ] 240 097     104K/s             ^C
[matej@hubmaier Fedora-Unity]$ 
Comment 2 Karsten Hopp 2008-03-26 12:32:02 EDT
wget-1.11.1 has been released yesterday, I think. I'll build a new package soon
to fix this.

*** This bug has been marked as a duplicate of 433606 ***

Note You need to log in before you can comment on or make changes to this bug.