Bug 439125 - mod_cache fails to retrieve objects cached for URLs which have been rewritten to target URLs with a query string
mod_cache fails to retrieve objects cached for URLs which have been rewritten...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: httpd (Show other bugs)
5.1
All Linux
low Severity medium
: rc
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-27 00:07 EDT by Dave Miller
Modified: 2011-02-08 08:36 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-08 08:36:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache Bugzilla 40805 None None None Never
Apache Bugzilla 41475 None None None Never

  None (edit)
Description Dave Miller 2008-03-27 00:07:23 EDT
Description of problem:

Using mod_rewrite in conjunction with mod_cache, when a requested object is
cached, the path to the cache object is calculated by hashing on the requested
URL (http://localhost/real). However, when retrieval of the object is attempted
on subsequent requests, the path to the cache object is calculated by hashing on
the requested URL *plus* the query string in the target of the RewriteRule.

Version-Release number of selected component (if applicable):
httpd-2.2.3-11.el5_1.3

How reproducible:
Always

Additional info:

Apache has already fixed this and backported it to 2.2 upstream.  Can we include
the patch?  mod_cache is kinda broke without it.  Thanks!
Comment 1 Jeremy Orem 2008-03-27 12:42:12 EDT
mod_cache is also affected by
https://issues.apache.org/bugzilla/show_bug.cgi?id=41475 (mod_cache does not
serve (CACHE_OUT) URLs which are url-escaped).  This has also been backported to
2.2 upstream (http://svn.apache.org/viewvc?view=rev&revision=539112).  

Can we also include this patch?  Should I file a new bug for this?  Thanks!
Comment 2 Joe Orton 2008-03-31 09:42:36 EDT
Thanks for the reports.  Please do file a separate bug for PR 41475.

(FYI, we're looking at a wholesale rebase of modules/cache to the 2.2.6/later
versions, to pick up the myriad fixes which have been made)
Comment 3 Jeremy Orem 2008-03-31 13:59:27 EDT
Filed Bug 439842.
Comment 4 Joe Orton 2009-05-15 11:38:05 EDT
This should be fixed as of the RHEL 5.3 httpd update (sorry, forgot to reference this bug) - are you still seeing this issue?
Comment 5 Dave Miller 2009-05-15 12:01:33 EDT
Jeremy was actually the one dealing with this...
Comment 6 Joe Orton 2011-02-08 08:36:26 EST
I'm closing this out since the referenced patches are included since 5.3 - let us know if you're still seeing issues.

Note You need to log in before you can comment on or make changes to this bug.