Bug 43916 - Logging in and out of X/KDE leaves ghost logins
Logging in and out of X/KDE leaves ghost logins
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
David Lawrence
:
: 36990 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-07 21:31 EDT by Need Real Name
Modified: 2007-04-18 12:33 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-18 06:59:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-06-07 21:31:02 EDT
Description of Problem:
After logging out of Xwindows the system doesn't logout the pts/x logins that where created for the X session and therefore everything that
uses this login count is wrong. (uptime, the user count in 'w')

How Reproducible:
Every time.

Steps to Reproduce:
1. Log into the console. (type 'who' to see how many are logged in) 
2. Start XFree86 with a window manager.
3. Exit XFree86 back to the console.  (type 'who' again to check users)
4. Note that typing 'w' shows the correct users all the time.

Actual Results:
Ghost users left in the system.  Uptime and other programs report the wrong amount of users.

Expected Results:
To show the right amount of users in the system at all times.

Additional Information:
Comment 1 Need Real Name 2001-06-07 22:27:05 EDT
Not sure if it's the util-linux package that has the problem, that was just my best guess.
Comment 2 Need Real Name 2001-06-08 13:48:51 EDT
Exact Steps to Reproduce:
 1. From a clean boot log into the console. (type 'who' to see how many are logged in) 
 2. Start XFree86 with startx and open an xterm. (mine's set to use KDE by default)
 3. Exit XFree86 back to the console.  (type 'who' again to check users)
 4. Note that typing 'w' shows the correct users all the time.
Comment 3 Mike Vanecek 2001-06-09 20:09:09 EDT
I see exactly the same error. Who and Last have incorrect information. Using w 
gives the correct information. A reboot clears the problem. I am also using 
KDE. I do not believe I saw this error when I installed and used Gnome.
Comment 4 Elliot Lee 2001-07-18 15:02:33 EDT
*** Bug 36990 has been marked as a duplicate of this bug. ***
Comment 5 Robert Peters 2001-08-15 13:19:42 EDT
I am having a similar problem. When I log in to a freshly booted computer, it 
shows an additional user to the standard :0 and pts that I am currently on. If 
I check the processes, I find that the only process associated with that 
terminal is /bin/cat with no arguments. (So cat will just sit there forever.) 
As with you, if I just logout, I have a "ghost" login that remains until 
reboot. I have found that if I "killall cat" prior to logout, I don't get the 
ghost logins. If this is not done prior to logout, then the cat process goes 
away, but the login remains. I haven't found what is starting cat yet though.
Comment 6 Elliot Lee 2001-09-20 19:27:48 EDT
Because this doesn't happen when using Gnome, I'm pretty sure this might have
been a KDE problem - reassigning.
Comment 7 Robert Peters 2001-09-20 20:09:42 EDT
It may be associated with kwrited.  At least on my system, when I took 
kwrited.desktop out of the shared autostart folder the problem went away on 
both my desktop and laptop.
Comment 8 markus.hillig 2001-09-22 17:30:26 EDT
There is a similar (the same?) bug regarding kwrited (later assigned to 
konsole) recorded in the kde bug list. It's bug #19649. It's marked there as 
'closed'. Don't know if it has something to do with this.
Comment 9 Need Real Name 2001-09-22 17:45:43 EDT
I don't think kwrited has anything to do with it.  I took krited.desktop out of the shared autostart folder and it didn't do anything.  I *might* have reduced 
the login count by one but the problem still leaves ghost logins.
Comment 10 Ngo Than 2003-06-18 06:59:02 EDT
it's fixed in current release

Note You need to log in before you can comment on or make changes to this bug.