Bug 439237 - F8 kernels with iwl4965 no longer connect to 802.11 B,G,N Access Point (B,G OK!)
Summary: F8 kernels with iwl4965 no longer connect to 802.11 B,G,N Access Point (B,G OK!)
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 8
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-03-27 17:14 UTC by Dax Kelson
Modified: 2008-04-04 15:45 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 15:45:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dax Kelson 2008-03-27 17:14:45 UTC
Description of problem:

I've been using Fedora 8 since it came it and it has worked at my house with my
DLink DIR-655 access point that does B, G, and N.

Until recently, (with a kernel errata update as of a few weeks ago (vague, I
know)) I can no longer get connected at home.

I've had no problem at the office though with our A, B, G access point.

Today I reconfigured my home access point and turned off N so it is now B,G
only. I'm now able to connect!

So it appears that my AP offering "N" isn't happy with the current F8 kernels
where with previous F8 kernels it was fine for the AP to offer "N".

Another interesting data point, with my AP doing all three (B,G,N) I booted the
Fedora 9 beta live CD and I was able to connect (using N even!). It isn't
entirely smooth sailing as I was able to download data initially at 9.3MB/sec
with no troubles but after a few minutes or so the speed slowed down to 400KB/sec.

Comment 1 John W. Linville 2008-03-27 17:32:58 UTC
What kernel version are you using?

Comment 2 Dax Kelson 2008-03-27 17:45:08 UTC
(In reply to comment #1)
> What kernel version are you using?

Sorry: 2.6.24.3-50.fc8

Comment 3 John W. Linville 2008-03-28 13:25:42 UTC
Is this the iwl4965 driver?  Or some other device?

Comment 4 Dax Kelson 2008-03-28 18:02:57 UTC
(In reply to comment #3)
> Is this the iwl4965 driver?  Or some other device?

Yes, the iwl4965 driver.

Comment 5 Dax Kelson 2008-04-04 15:45:24 UTC
fixed in 2.6.24.4-64.fc8.


Note You need to log in before you can comment on or make changes to this bug.