Bug 439239 - Anaconda doesn't "switch CDs" when installing from CD ISO images
Anaconda doesn't "switch CDs" when installing from CD ISO images
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-27 13:20 EDT by Nils Philippsen
Modified: 2008-04-01 12:19 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-01 12:19:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nils Philippsen 2008-03-27 13:20:01 EDT
Description of problem:
When anaconda needs to mount a new ISO image onto /mnt/source, it just stays
there "reattempting to download" some package (which would be on the next ISO
image).

Version-Release number of selected component (if applicable):
anaconda as of F9 beta

How reproducible:
reproducible

Steps to Reproduce:
1. Install from CD ISO images via NFS
  
Actual results:
"reattempting to download ..." -> fails, offers "retry/reboot"

Expected results:
- umounts old image, mounts next image autonomously
- doesn't attempt to "download" a pkg file multiple times when installing
(quasi-) locally via NFS

Additional info:
I umounted the old image and mounted the new one manually, which got me to a
certain point when it barfed over the liferea pkg file on the 5th disk, which
was corrupt.
Comment 1 Chris Lumens 2008-03-28 15:03:06 EDT
This is working fine for me with anaconda-11.4.0.61, both booting off the
netinst.iso and without.  Is there anything particular that you are doing?  Can
you attach the /tmp/anaconda.log if you are still seeing problems here?
Comment 2 Nils Philippsen 2008-04-01 09:29:47 EDT
The beta was shipped with 11.4.0.55 -- have you fixed something in between or
shall we investigate this further?
Comment 3 Chris Lumens 2008-04-01 11:20:08 EDT
Yes, there were some nfsiso-specific fixes since 11.4.0.55.
Comment 4 Nils Philippsen 2008-04-01 12:19:49 EDT
In that case let's close it.

Note You need to log in before you can comment on or make changes to this bug.