Bug 439252 - fence_apc doesn't know about -T test option
fence_apc doesn't know about -T test option
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
5.1
All Linux
low Severity low
: rc
: ---
Assigned To: Marek Grac
GFS Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-27 14:11 EDT by Thorsten Scherf
Modified: 2009-04-16 18:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-06 09:53:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thorsten Scherf 2008-03-27 14:11:15 EDT
Description of problem:
fence_apc man page states there is a test option -T for the agent:

-T     Test only.  Answer NO to the confirmation prompt instead of YES.

when I call the agent it prints out wrong option usage.

Version-Release number of selected component (if applicable):
fence_apc 2.0.73 (cman-2.0.73-1.el5_1.5)

How reproducible:
fence_apc -v -a ip -l login -p password -n port -T

Steps to Reproduce:
1.
2.
3.
  
Actual results:
wrong usage

Expected results:
test call

Additional info:
Comment 1 Jim Parsons 2008-04-14 15:31:35 EDT
Hmmm...is this a feature you desire? Or should I edit the man page?
Comment 2 Thorsten Scherf 2008-04-14 18:13:04 EDT
well, it would be nice to have. and since the man page already have an entry for
this....
Comment 3 Marek Grac 2009-03-06 09:53:45 EST
'-T' option was agent dependant on APC it worked as you wrote but on some other it was just an alias to test outlet status. In current release -T works same as '-o status'. You are right that manual pages should be in sync with binaries, I'm going to create a new bug for this problem.

Note You need to log in before you can comment on or make changes to this bug.