Bug 439293 - gnome-power-manager and pulseaudio constantly using 3-4% CPU
gnome-power-manager and pulseaudio constantly using 3-4% CPU
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-27 18:29 EDT by Dan Winship
Modified: 2013-03-05 22:55 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-02 06:16:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Winship 2008-03-27 18:29:10 EDT
pulseaudio is constantly using a small amount of CPU:

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
13328 danw      20   0 36340 5236 3384 S  3.6  0.3   7:16.48 pulseaudio         

even though no audio is playing.

strace repeatedly shows:

poll([{fd=3, events=POLLIN}, {fd=38, events=POLLIN}, {fd=37,
events=POLLIN|POLLOUT, revents=POLLIN|POLLOUT}, {fd=36, events=POLLIN}, {fd=35,
events=POLLIN}, {fd=34, events=POLLIN}, {fd=33, events=POLLIN}, {fd=32,
events=POLLIN}, {fd=31, events=POLLIN}, {fd=30, events=POLLIN}, {fd=16,
events=POLLIN}, {fd=29, events=POLLIN}, {fd=28, events=POLLIN}, {fd=22,
events=POLLIN}, {fd=27, events=POLLIN}, {fd=9, events=POLLIN}, {fd=15,
events=POLLIN}, {fd=21, events=POLLIN}, {fd=26, events=POLLIN}, {fd=25,
events=POLLIN}, {fd=24, events=POLLIN}, {fd=23, events=POLLIN}, {fd=20,
events=POLLIN}, {fd=14, events=POLLIN}, {fd=10, events=POLLIN|POLLERR|POLLHUP},
{fd=10, events=0}, {fd=7, events=POLLIN}, {fd=5, events=POLLIN}], 28, 1276) = 1

happening about once every millisecond. lsof shows that fd 37 is
/tmp/pulse-danw/native, and that no one except pulseaudio is currently using
that socket.

killing and restarting pulseaudio caused it to stop sucking up CPU.
Interestingly, it also caused gnome-power-manager to jump from 3% CPU usage to
99% CPU usage, suggesting that the problem is some sort of interaction between
pulseaudio and gnome-power-manager
Comment 1 Dan Winship 2008-03-27 20:43:03 EDT
When I suspend and resume, pulseaudio and gnome-power-manager start sucking up
CPU again. This time I killed gnome-power-manager instead of pulseaudio, and
pulseaudio immediately settled back down. So it looks like it's g-p-m's fault,
not pulseaudio's.
Comment 2 Richard Hughes 2008-04-30 05:19:26 EDT
Yup, guilty as charged. I'm guessing this does not happen with rawhide now, right?
Comment 3 Dan Winship 2008-05-01 09:37:31 EDT
looks like it works fine with the latest F9 packages

Note You need to log in before you can comment on or make changes to this bug.