Bug 439313 - pulseaudio avc on first boot.
pulseaudio avc on first boot.
Status: CLOSED DUPLICATE of bug 438215
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-27 20:05 EDT by Dave Jones
Modified: 2015-01-04 17:30 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-28 16:56:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2008-03-27 20:05:59 EDT
on a freshly installed system, right after I boot I get this..

$ sealert -l 0aab35e4-ffd3-488a-9d61-556fea2a36ff

Summary:

SELinux is preventing pulseaudio (xdm_t) "getcap" to <Unknown> (xdm_t).

Detailed Description:

SELinux denied access requested by pulseaudio. It is not expected that this
access is required by pulseaudio and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Or you can disable
SELinux protection altogether. Disabling SELinux protection is not recommended.
Please file a bug report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi)
against this package.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Objects                None [ process ]
Source                        pulseaudio
Source Path                   /usr/bin/pulseaudio
Port                          <Unknown>
Host                          northwood
Source RPM Packages           pulseaudio-0.9.8-12.fc9
Target RPM Packages           
Policy RPM                    selinux-policy-3.3.1-24.fc9
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     northwood
Platform                      Linux northwood 2.6.25-0.161.rc7.fc9.i686 #1 SMP
                              Wed Mar 26 17:36:04 EDT 2008 i686 i686
Alert Count                   6
First Seen                    Thu Mar 27 15:59:07 2008
Last Seen                     Thu Mar 27 16:01:13 2008
Local ID                      0aab35e4-ffd3-488a-9d61-556fea2a36ff
Line Numbers                  

Raw Audit Messages            

host=northwood type=AVC msg=audit(1206648073.730:11): avc:  denied  { getcap }
for  pid=2465 comm="pulseaudio" scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023
tcontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tclass=process

host=northwood type=SYSCALL msg=audit(1206648073.730:11): arch=40000003
syscall=184 success=no exit=-13 a0=9cdc334 a1=0 a2=3020f0 a3=9cdc330 items=0
ppid=2456 pid=2465 auid=4294967295 uid=42 gid=42 euid=42 suid=42 fsuid=42
egid=42 sgid=42 fsgid=42 tty=(none) ses=4294967295 comm="pulseaudio"
exe="/usr/bin/pulseaudio" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)


also..

host=northwood type=AVC msg=audit(1206648073.731:12): avc:  denied  { setcap }
for  pid=2465 comm="pulseaudio" scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023
tcontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tclass=process

host=northwood type=SYSCALL msg=audit(1206648073.731:12): arch=40000003
syscall=185 success=no exit=-13 a0=9cdc334 a1=9cdc33c a2=3020f0 a3=0 items=0
ppid=2456 pid=2465 auid=4294967295 uid=42 gid=42 euid=42 suid=42 fsuid=42
egid=42 sgid=42 fsgid=42 tty=(none) ses=4294967295 comm="pulseaudio"
exe="/usr/bin/pulseaudio" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)
Comment 1 Daniel Walsh 2008-03-28 03:19:33 EDT
This is a pulseaudio bug.  It should not be setuid.
Comment 2 Lennart Poettering 2008-03-28 16:56:05 EDT
This is a SELinux Policy issue. 

PA should be suid.

*** This bug has been marked as a duplicate of 438215 ***

Note You need to log in before you can comment on or make changes to this bug.