Bug 439393 - Lenovo T60 & T61 require "pix.intel_via_libata=1 ide0=noprobe" by default
Lenovo T60 & T61 require "pix.intel_via_libata=1 ide0=noprobe" by default
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
All Linux
high Severity medium
: rc
: ---
Assigned To: Prarit Bhargava
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-28 10:35 EDT by Prarit Bhargava
Modified: 2008-03-28 12:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-28 12:12:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prarit Bhargava 2008-03-28 10:35:49 EDT
Description of problem:

Lenovo T60 & T61 laptops require  "pix.intel_via_libata=1 ide0=noprobe" on the
boot line by default.  Hopefully we can automate this so users do not have to
add this/anaconda doesn't have to add this.
Comment 1 Prarit Bhargava 2008-03-28 11:20:40 EDT
Okay AFAICT, ide0=noprobe has never been special cased by anaconda or the kernel.  

Alan, do you think I should automagically set intel_via_libata=1 for t60 & t61 ?
 Or is it just not worth it?

P.
Comment 2 Alan Cox 2008-03-28 11:36:24 EDT
Definitely not: We have existing T60/61 users not using this feature who should
not be exposed to a change of interface, device name and the risk of regressions
unless they "opt in" to it.

Note You need to log in before you can comment on or make changes to this bug.