Bug 439406 - regression: eject 2.1.5-7 breaks ATA dvd ejection
regression: eject 2.1.5-7 breaks ATA dvd ejection
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: eject (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Zdenek Prikryl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-28 11:50 EDT by Alessandro Suardi
Modified: 2008-04-09 06:04 EDT (History)
0 users

See Also:
Fixed In Version: 2.1.5-8.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-09 01:12:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alessandro Suardi 2008-03-28 11:50:50 EDT
Description of problem:

Updating eject to 2.1.5-7.fc8.i386 causes it to not eject a dvd
 and complain instead with this message:

eject: did not find a device /dev/sr0 in /sys/block/

Version-Release number of selected component (if applicable):

2.1.5-7.fc8.i386

How reproducible:

100%

Steps to Reproduce:
1. insert dvd in cdrom while in GNOME
2. wait for the nautilus window to show contents of dvd
3. try ejecting, either with command-line eject or with rightclick->eject
  
Actual results:

commandline complains as described above.
GNOME window error appears saying it can't eject the disc.

Expected results:

disc is ejected.

Additional info:

eject-2.1.5-6.fc8.i386 works correctly, and at the moment
 I rpm'd --oldpackage said version.

[asuardi@sandman ~]$ eject
eject: did not find a device /dev/sr0 in /sys/block/
[asuardi@sandman ~]$ df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/sda6              4738480   4134416    359476  93% /
tmpfs                  1033716       332   1033384   1% /dev/shm
/dev/sda7              4738480   3979852    514040  89% /fedora7
/dev/sda8             38266444  33726696   2595888  93% /share
/dev/sda1              9288792   5188176   3628712  59% /download
/dev/sr0               4565930   4565930         0 100% /cdrom
[asuardi@sandman ~]$ ls -l /sys/block/sr0
lrwxrwxrwx 1 root root 0 2008-03-28 13:38 /sys/block/sr0 ->
../devices/pci0000:00/0000:00:1f.2/host1/target1:0:0/1:0:0:0/block/sr0

<su to root, downgrade to eject-2.1.5-6>
[root@sandman packages]# rpm -Uvh --oldpackage eject-2.1.5-6.fc8.i386.rpm 
Preparing...                ########################################### [100%]
   1:eject                  ########################################### [100%]

<back to my original window>

[asuardi@sandman ~]$ eject
[asuardi@sandman ~]$ 

<disc gets ejected>

kernel is 2.6.25-rc7-git2 from kernel.org.
Comment 1 Alessandro Suardi 2008-03-28 11:52:51 EDT
Forgot to mention that this is a bog-standard DVD drive in a Dell Latitude D610
laptop, 32-bit Pentium-M 1.8Ghz.
Comment 2 Zdenek Prikryl 2008-03-31 06:49:17 EDT
Yes, this is caused by changes is sysfs. /sys/block/sr0 is now a symlink instead
of a directory. It is fixed in rawhide, so I'll backport it to F{8,7}.
Comment 3 Fedora Update System 2008-04-02 05:02:48 EDT
eject-2.1.5-8.fc8 has been submitted as an update for Fedora 8
Comment 4 Fedora Update System 2008-04-02 05:12:36 EDT
eject-2.1.5-8.fc7 has been submitted as an update for Fedora 7
Comment 5 Fedora Update System 2008-04-09 01:12:55 EDT
eject-2.1.5-8.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2008-04-09 01:15:44 EDT
eject-2.1.5-8.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Alessandro Suardi 2008-04-09 06:04:38 EDT
2.1.5-8-fc8 fixes the regression for me. Thanks !

Note You need to log in before you can comment on or make changes to this bug.