Bug 439408 - Traceback when trying to start s-c-k. "Couldn't start in graphical mode, starting in text mode."
Traceback when trying to start s-c-k. "Couldn't start in graphical mode, star...
Status: CLOSED DUPLICATE of bug 439402
Product: Fedora
Classification: Fedora
Component: system-config-keyboard (Show other bugs)
rawhide
i386 Linux
low Severity low
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-28 11:53 EDT by Adrian "Adi1981" P.
Modified: 2009-01-07 13:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-28 11:58:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adrian "Adi1981" P. 2008-03-28 11:53:01 EDT
Description of problem:

When starting s-c-k it crashes with:

# system-config-keyboard
Uruchomienie w trybie graficznym nie powiodło się. Uruchamianie w trybie tekstowym.
Traceback (most recent call last):
  File "/usr/share/system-config-keyboard/system-config-keyboard.py", line 78,
in <module>
    useTextMode()
  File "/usr/share/system-config-keyboard/system-config-keyboard.py", line 37,
in useTextMode
    import keyboard_tui
  File "/usr/share/system-config-keyboard/keyboard_tui.py", line 29, in <module>
    import rhpl.keyboard
  File "/usr/lib/python2.5/site-packages/rhpl/keyboard.py", line 50
    if kb.GetPropertyString("info.product").startswith("Sun Type"):
                                                                  ^
SyntaxError: invalid syntax

Version-Release number of selected component (if applicable):
system-config-keyboard-1.2.14-1.fc9.noarch

How reproducible:
Always
Comment 1 Adrian "Adi1981" P. 2008-03-28 11:58:33 EDT

*** This bug has been marked as a duplicate of 439402 ***

Note You need to log in before you can comment on or make changes to this bug.