This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 439414 - extremely large tooltips
extremely large tooltips
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-28 12:13 EDT by Zack Cerza
Modified: 2008-04-07 05:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 05:23:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
what about something like this? (888 bytes, patch)
2008-03-28 15:29 EDT, Richard Hughes
no flags Details | Diff

  None (edit)
Description Zack Cerza 2008-03-28 12:13:52 EDT
Description of problem:
If PK has enough pending transactions, gnome-pk will happily create a tooltip
that doesn't fit onscreen. 

For example, I cherry-picked maybe 30 updates from 200 or so by clicking "Update
Package" on each of them. They're added to the queue (along with tons of extra
"get update detail" and "get updates" items). Mousing over the gnome-pk icon
shows a tooltip that's taller than my screen itself.

Version-Release number of selected component (if applicable):
gnome-packagekit-0.1.9-4.fc9.i386
Comment 1 Richard Hughes 2008-03-28 14:06:55 EDT
Ahh, we've fixed the cherry pick problem by making them checkboxes you can
select. How many lines do you think a "too big" tooltip is (so we can add ...
for the rest).
Comment 2 Zack Cerza 2008-03-28 14:54:29 EDT
If we can't figure out how tall the tooltip is going the be (so we can compare
it to the screen height) I'm thinking the cap should be something like, I don't
know, 25? It's just a guess.

Also, instead of "..." it would be a good idea to put "(56 more transactions)"
or some such text.
Comment 3 Richard Hughes 2008-03-28 15:29:22 EDT
Created attachment 299515 [details]
what about something like this?
Comment 4 Zack Cerza 2008-03-28 15:57:05 EDT
Didn't actually compile/test it, but it looks like the right fix.
Comment 5 Richard Hughes 2008-03-28 16:19:14 EDT
I've added this into git, many thanks.

Note You need to log in before you can comment on or make changes to this bug.