Bug 43942 - /usr/sbin/kbdconfig crashes with bogus arguments
Summary: /usr/sbin/kbdconfig crashes with bogus arguments
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kbdconfig   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-08 10:15 UTC by Pekka Savola
Modified: 2014-03-17 02:21 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-20 20:17:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pekka Savola 2001-06-08 10:15:12 UTC
If you run /usr/sbin/kbdconfig xyzzy, kbdconfig segfaults.

This is caused by a brainfart when coding, apparently (also added \n for
good measure). ;-)

--- kbdconfig-1.9.12/kbdconfig.c	Thu Jan 18 02:54:57 2001
+++ kbdconfig-1.9.12.n/kbdconfig.c	Fri Jun  8 10:15:57 2001
@@ -308,7 +308,7 @@
     }
 
     if (poptGetArg(optCon)) {
-	sprintf(_("%s: unexpected argument"), progName);
+	fprintf(stderr, _("%s: unexpected argument\n"), progName);
 	return 2;
     }

Comment 1 Pekka Savola 2001-06-20 20:17:39 UTC
Whoops, wrong component.

Comment 2 Bill Nottingham 2001-07-10 19:23:04 UTC
will be fixed in 1.9.13-1.


Note You need to log in before you can comment on or make changes to this bug.