This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 439422 - OpenOffice.org cannot open MS Office 2007 files
OpenOffice.org cannot open MS Office 2007 files
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
9
All All
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
http://katana.oooninja.com/w/odf-conv...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-28 13:26 EDT by Răzvan Sandu
Modified: 2014-03-16 23:13 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-08 09:37:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Răzvan Sandu 2008-03-28 13:26:24 EDT
Description of problem:

The current version of OpenOffice.org (2.4.0) cannot open & save Microsoft
Office 2007 files (.docx, .pptx, .xlsx). This is a serious stop for users, since
these files has begun to spread.

Until this functionality is available in OpenOffice 3.0, please consider
including in Fedora the odf-converter-integrator package, which is available at

http://katana.oooninja.com/w/odf-converter-integrator


A pre-made RPM file for Fedora is also available at this address.


Regards,
Răzvan
Comment 1 Bill Nottingham 2008-03-28 13:47:18 EDT
Are you volunteering to join the Fedora project as a packager and maintain it? 
Comment 2 Răzvan Sandu 2008-03-28 13:55:33 EDT
Hello,

Yes, of course, but I need some precise guidance, since it will the first time
for me to do so. Also, please note that I'm not a programmer and it's not my
code (alpha code...)

Otherwise, I'll be *very* enthusiastic about doing it.

Regards,
Răzvan
Comment 3 Rex Dieter 2008-03-28 14:33:38 EDT
This should get you started:
http://fedoraproject.org/wiki/PackageMaintainers/Join
Comment 4 Caolan McNamara 2008-03-29 09:09:29 EDT
FWIW from the Oo side in theory this should be redundant with OOo 3.0.0 in the
F-10 timescale
Comment 5 Bug Zapper 2008-05-14 04:22:32 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Răzvan Sandu 2008-10-08 09:37:33 EDT
we can close this, since OpenOffice 3.0 is almost out.

Razvan

Note You need to log in before you can comment on or make changes to this bug.