Bug 439497 - autofs hang on startup
autofs hang on startup
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: autofs (Show other bugs)
5.1
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: Ian Kent
Brock Organ
http://www.mail-archive.com/autofs@li...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-28 15:53 EDT by Ragnar Kjørstad
Modified: 2009-01-20 16:45 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:45:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ragnar Kjørstad 2008-03-28 15:53:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.13) Gecko/20080325 Fedora/2.0.0.13-1.fc8 Firefox/2.0.0.13

Description of problem:
When I start /etc/init.d/autofs it hangs forever.

Version-Release number of selected component (if applicable):
autofs-5.0.1-0.rc2.55

How reproducible:
Always


Steps to Reproduce:
1. Boot a headless system with no keyboard or mouse and with / as tmpfs
2. Start /etc/init.d/autofs start


Actual Results:
Autofs hangs

Expected Results:
Autofs should have started and bash should have returned to the prompt.

Additional info:
I'm not sure if the fact that the system is headless or that / is tmpfs is relevant.

However, as reported in http://www.mail-archive.com/autofs@linux.kernel.org/msg06460.html, replacing /dev/random with a symlink to /dev/urandom fixes the problem.
Comment 1 Ian Kent 2008-03-29 00:50:59 EDT
I haven't checked into this yet, thanks for the reminder.
Comment 2 RHEL Product and Program Management 2008-06-02 16:11:32 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Istvan Marko 2008-06-11 17:53:17 EDT
I am running into this as well. I believe the hangs are caused by the
calls to seed_random() which in turn tries to read /dev/random and
that hangs on entropy starved systems. Changing Patch66:
autofs-5.0.1-rc3-random-selection.patch to use /dev/urandom instead of
/dev/random is the easy fix. /dev/random is an overkill for this
anyway.
Comment 8 errata-xmlrpc 2009-01-20 16:45:40 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0178.html

Note You need to log in before you can comment on or make changes to this bug.