Bug 439585 - initrd unbootable when made on ext2
initrd unbootable when made on ext2
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Eric Sandeen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-29 06:39 EDT by Walkie
Modified: 2008-03-30 06:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-30 06:06:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Walkie 2008-03-29 06:39:19 EDT
Description of problem:
when I install/upgrade new kernels on ext2 the boot of new kernel with made
during install initrd stops with following messages:

mount: error mounting /dev/root on /sysroot as ext2: Invalid argument
setuproot: error moving /dev failed: No such file or directory
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
switchroot: mount failed: No such file or directory

remark - the original fs was ext3 because I was not able to select ext2 when
installing from livecd I changed ext3 to ext2 in fstab

workaround - change ext2 to ext3 in fstab, remove new kernel, reboot, reinstall
the new kernel with recreating initrd, change ext3 to ext2 back, reboot -
everything works

Version-Release number of selected component (if applicable):
i tried that with last kernels from 2.6.23.14 to 2.6.24.3-50 with full updated
system
not tried it with earlier kernels

How reproducible:
every time

Steps to Reproduce:
1. install new fedora on ext3
2. change ext3 to ext2 in fstab
3. reboot and install/upgrade kernel on ext2
  
Actual results:
unbootable initrd

Expected results:
normal boot

Additional info:
http://www.smolts.org/client/show/pub_10600e7a-652c-45c1-96ba-ccd33e66f10c
Comment 1 Eric Sandeen 2008-03-29 12:41:30 EDT
were there any messages from ext2 before the ones you pasted?

Thanks,
-Eric
Comment 2 Walkie 2008-03-30 04:07:06 EDT
There no ext2 messages in quiet mode, there is some other messages, but they are
exactly same as the messages during normal boot.
I tried disable quiet mode and get following messages just after info about
disks and partitions:

Creating root device.
Mounting root filesystem.
EXT2-fs: sda5: couldn't mount because of unsupported optional features (4).
mount: error mounting /dev/root on /sysroot as ext2: Invalid argument
Setting up other filesystems.
Setting up new root fs
setuproot: moving /dev failed: No such file or directory
no fstab.sys, mounting internal defaults
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
Switching to new root and running unit.
unmounting old /dev
unmounting old /proc
unmounting old /sys
switchroot: mount failed: No such file or directory
Booting has failed

The normal boot looks like:

Creating root device.
Mounting root filesystem.
EXT3-fs: INFO: recovery required on readonly filesystem.
EXT3-fs: write accsess will be enabled during recovery.
kjornald starting. Commit interval 5 seconds
EXT3-fs: recovery complete.
EXT3-fs: mounted filesystem with ordered data mode.
Setting up other filesystems.
Setting up new root fs
no fstab.sys, mounting internal defaults
Switching to new root and running unit.
unmounting old /dev
unmounting old /proc
unmounting old /sys

I blame inproper filesystem change from ext3 to ext2 in this bug.
But I repeat - I was unable to select native ext2 during install from livecd,
and I asked on #fedora how to correcly change root ext3 to ext2 and got answer -
just change in fstab.
Comment 3 Walkie 2008-03-30 06:06:00 EDT
I ask to close the bug.
It is only my mistake.
I found instructions to correctly change fs type on
http://www.redhat.com/docs/manuals/linux/RHL-7.3-Manual/ref-guide/s1-filesystem-ext2-revert.html
After doing
tune2fs -O ^has_journal /dev/sda5
the both kernels with initrd made on ext3 and incorrectly changed ext2 boots ok.
Its correct - the earlier ext2 driver should not work with later ext3 features
to not to mess things. The later ext3 driver supports the earlier things.
The solution should be somewhere on fedorasolved, but if google indexing this
page, people will be able to found solution here.
Sorry for distribing.

Note You need to log in before you can comment on or make changes to this bug.