Bug 439618 - yum throws an exception installing skype i586 pkg on x86_64
yum throws an exception installing skype i586 pkg on x86_64
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-29 13:29 EDT by Mat Booth
Modified: 2014-01-21 18:02 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-29 16:30:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Yum stack trace (2.62 KB, text/plain)
2008-03-29 13:29 EDT, Mat Booth
no flags Details

  None (edit)
Description Mat Booth 2008-03-29 13:29:55 EDT
Description of problem:

I downloaded the Skype rpm from here: http://www.skype.com/go/getskype-linux-fc7

And tried to install it on my F9 Rawhide installation by double clicking the rpm
file on my desktop. Skype is an i586 package and this is an x86_64 machine with
no i386 packages installed at all. Yum throws the following exception:

Error Type: <type 'exceptions.KeyError'>
Error Value: 'unknown header tag'

See attached stack trace.

When installing with "rpm -ivh" in a terminal, it fails the dependency check and
lists missing deps. (As you'd expect because the appropriate i386 versions of
the dependencies are missing.)

Version-Release number of selected component (if applicable):
yum.noarch    3.2.13-1.fc9   installed
Trying to install skype-2.0.0.68-fc5.i586.rpm

How reproducible:
Very.

Steps to Reproduce:
1. Download Skype Fedora rpm.
2. Double click to install.
  
Actual results:
Yum throws.

Expected results:
Fail gracefully, at the very least by telling me deps are missing. (I'm not sure
what the correct behaviour is in this circumstance, but it certainly shouldn't
crash.)
Comment 1 Mat Booth 2008-03-29 13:29:55 EDT
Created attachment 299585 [details]
Yum stack trace
Comment 2 Seth Vidal 2008-03-29 13:38:51 EDT
You didn't actually install it with yum, you installed it through package kit
(by double clicking, right?)

That being the case it looks like the package kit backend for yum isn't catching
the exception of whatever is not found in that package's header.

Try installing it with yum using:

yum install /path/to/rpm and see if you get the same error.
thanks
Comment 3 Mat Booth 2008-03-29 15:29:33 EDT
(In reply to comment #2)
> You didn't actually install it with yum, you installed it through package kit
> (by double clicking, right?)
> 

Yes that's right. I'm was mistaken in filing this bug under Yum instead of
PackageKit. The stack trace mentions yum a lot, you see... ;-)

> That being the case it looks like the package kit backend for yum isn't catching
> the exception of whatever is not found in that package's header.
> 
> Try installing it with yum using:
> 
> yum install /path/to/rpm and see if you get the same error.
> thanks
> 

Installing it the way you suggest works a treat.

And it looks like updating to the version of PackageKit that appeared in Rawhide
today (from 0.1.9-2.fc9 to 0.1.10-1.fc9) fixes it. Just updated all my
*packagekit* packages and tried again this time worked perfectly!

Note You need to log in before you can comment on or make changes to this bug.