Bug 43966 - Kernel do not add shared memmory
Kernel do not add shared memmory
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-08 11:37 EDT by Helio Ferenhof
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-08 11:37:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Helio Ferenhof 2001-06-08 11:37:02 EDT
Description of Problem:
The Kernel at Version 7.1 do not load the shared memory enven if u make cat
"33554432" > /proc/sys/kernel/shmmax 

use free comand to see if u have shared mem.

[root@redhat.com /root]# free
             total       used       free     shared    buffers     cached
Mem:        125704     123656       2048          0       2600      49808
-/+ buffers/cache:      71248      54456
Swap:       415792        576     415216
[root@redhat.com /root]#



How Reproducible:
Every Time

Steps to Reproduce:
1. free
2. cat "33554432" > /proc/sys/kernel/shmmax 
3. free
Actual Results:

1. U recive shared memory iqual to ZERO
2. U add 33554432 to the shared memory
3. U see how mutch mem u got .. and u still with ZERO shared mem.

Expected Results:
at pass 3 to have 33554432 shered mem.


Additional Information:
Comment 1 Arjan van de Ven 2001-06-08 11:45:09 EDT
Thanks for the report.

"shared" has never been THIS kind of shared memory. It was the amount
of memory shared between programs due to reuse of code. (eg if you had 5 bash
programs, they would share the memory needed for the instructions to execute the
program). In 2.4, this has been stopped as accounting it was very expensive.

VERY recently, someone else came to the idea that shared memory as you mean it,
would be great to have accounted here and future kernels from us will actually
do this.

I'll mark this bug as "deferred" as we will get it fixed, just not today ;)

Note You need to log in before you can comment on or make changes to this bug.