This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 439673 - evince crashes on performanceTR.pdf
evince crashes on performanceTR.pdf
Status: CLOSED DUPLICATE of bug 438970
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-30 05:35 EDT by Scott Tsai
Modified: 2008-03-31 11:18 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-31 11:18:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Scott Tsai 2008-03-30 05:35:59 EDT
Description of problem:
evince crashes on http://www.research.att.com/~bs/performanceTR.pdf

Version-Release number of selected component (if applicable):
evince-2.22.0-3.fc9.x86_64
poppler-0.7.3-1.fc9.x86_64
cairo-1.5.14-1.fc9.x86_64

How reproducible:
always

Steps to Reproduce:
1. Download http://www.research.att.com/~bs/performanceTR.pdf
2. GNOME_DISABLE_CRASH_DIALOG=1 evince performanceTR.pdf

  
Actual results:
**
** ERROR:(ev-poppler.cc:868):EvLinkDest* ev_link_dest_from_dest(PdfDocument*,
PopplerDest*): assertion failed: (dest != NULL)
Aborted (core dumped)


Expected results:
evince not crashing.

Additional info:
(gdb) thread apply all bt

Thread 2 (process 3464):
#0  0x0000000000f75ff2 in select () from /lib64/libc.so.6
#1  0x0000003ba0408a96 in _xcb_conn_wait (c=<value optimized out>, cond=<value
optimized out>, vector=<value optimized out>, count=<value optimized out>) at
xcb_conn.c:340
#2  0x0000003ba0409139 in _xcb_out_send (c=<value optimized out>, vector=<value
optimized out>, count=<value optimized out>) at xcb_out.c:279
#3  0x0000003ba04096be in xcb_send_request (c=<value optimized out>,
flags=<value optimized out>, vector=<value optimized out>, req=<value optimized
out>) at xcb_out.c:55
#4  0x0000003ba084c217 in _XPutXCBBuffer (dpy=<value optimized out>) at
xcb_lock.c:148
#5  0x0000003ba084d70f in _XSend (dpy=<value optimized out>, data=<value
optimized out>, size=<value optimized out>) at xcb_io.c:233
#6  0x0000003ba0839386 in PutSubImage (dpy=<value optimized out>, d=<value
optimized out>, gc=<value optimized out>, image=<value optimized out>, 
    req_xoffset=<value optimized out>, req_yoffset=<value optimized out>,
x=<value optimized out>, y=<value optimized out>, req_width=<value optimized out>, 
    req_height=<value optimized out>, dest_bits_per_pixel=<value optimized out>,
dest_scanline_pad=<value optimized out>) at PutImage.c:804
#7  0x0000003ba083857d in PutSubImage (dpy=<value optimized out>, d=<value
optimized out>, gc=<value optimized out>, image=<value optimized out>, 
    req_xoffset=<value optimized out>, req_yoffset=<value optimized out>,
x=<value optimized out>, y=<value optimized out>, req_width=<value optimized out>, 
    req_height=<value optimized out>, dest_bits_per_pixel=<value optimized out>,
dest_scanline_pad=<value optimized out>) at PutImage.c:919
#8  0x0000003ba0839580 in XPutImage (dpy=<value optimized out>, d=<value
optimized out>, gc=<value optimized out>, image=<value optimized out>,
req_xoffset=<value optimized out>, 
    req_yoffset=<value optimized out>, x=Could not find the frame base for
"XPutImage".
) at PutImage.c:1029
#9  0x0000003c3864d27a in _draw_image_surface (surface=<value optimized out>,
image=<value optimized out>, src_x=<value optimized out>, src_y=<value optimized
out>, 
    width=<value optimized out>, height=<value optimized out>, dst_x=Could not
find the frame base for "_draw_image_surface".
) at cairo-xlib-surface.c:959
#10 0x0000003c3864d528 in _cairo_xlib_surface_clone_similar
(abstract_surface=<value optimized out>, src=<value optimized out>, src_x=<value
optimized out>, 
    src_y=<value optimized out>, width=<value optimized out>, height=<value
optimized out>, clone_out=Could not find the frame base for
"_cairo_xlib_surface_clone_similar".
) at cairo-xlib-surface.c:1086
#11 0x0000003c386213da in _cairo_surface_clone_similar (surface=<value optimized
out>, src=<value optimized out>, src_x=<value optimized out>, src_y=<value
optimized out>, 
    width=<value optimized out>, height=<value optimized out>, clone_out=Could
not find the frame base for "_cairo_surface_clone_similar".
) at cairo-surface.c:1093
#12 0x0000003c38626165 in _cairo_pattern_acquire_surface (pattern=<value
optimized out>, dst=<value optimized out>, x=<value optimized out>, y=<value
optimized out>, 
    width=<value optimized out>, height=<value optimized out>, surface_out=Could
not find the frame base for "_cairo_pattern_acquire_surface".
) at cairo-pattern.c:1725
#13 0x0000003c386276bc in _cairo_pattern_acquire_surfaces (src=<value optimized
out>, mask=<value optimized out>, dst=<value optimized out>, src_x=<value
optimized out>, 
    src_y=<value optimized out>, mask_x=<value optimized out>, mask_y=Could not
find the frame base for "_cairo_pattern_acquire_surfaces".
) at cairo-pattern.c:1923
#14 0x0000003c3864bb96 in _cairo_xlib_surface_composite (op=<value optimized
out>, src_pattern=<value optimized out>, mask_pattern=<value optimized out>, 
    abstract_dst=<value optimized out>, src_x=<value optimized out>,
src_y=<value optimized out>, mask_x=Could not find the frame base for
"_cairo_xlib_surface_composite".
) at cairo-xlib-surface.c:1512
#15 0x0000003c386211be in _cairo_surface_composite (op=<value optimized out>,
src=<value optimized out>, mask=<value optimized out>, dst=<value optimized out>, 
    src_x=<value optimized out>, src_y=<value optimized out>, mask_x=<value
optimized out>, mask_y=<value optimized out>, dst_x=<value optimized out>, 
    dst_y=<value optimized out>, width=<value optimized out>, height=<value
optimized out>) at cairo-surface.c:1224
#16 0x0000003c3862345b in _clip_and_composite_trapezoids (src=<value optimized
out>, op=<value optimized out>, dst=<value optimized out>, traps=<value
optimized out>, 
    clip=<value optimized out>, antialias=<value optimized out>) at
cairo-surface-fallback.c:449
#17 0x0000003c38623b74 in _cairo_surface_fallback_paint (surface=<value
optimized out>, op=<value optimized out>, source=<value optimized out>) at
cairo-surface-fallback.c:709
#18 0x0000003c38620930 in _cairo_surface_paint (surface=<value optimized out>,
op=<value optimized out>, source=<value optimized out>) at cairo-surface.c:1429
#19 0x0000003c3861155a in _cairo_gstate_paint (gstate=<value optimized out>) at
cairo-gstate.c:894
#20 0x0000003c3860a3f9 in cairo_paint (cr=<value optimized out>) at cairo.c:1939
#21 0x0000000000433d3b in ?? ()
#22 0x0000000000000000 in ?? ()

Thread 1 (process 3465):
#0  0x0000000000ec9ef5 in raise () from /lib64/libc.so.6
#1  0x0000000000ecba63 in abort () from /lib64/libc.so.6
#2  0x0000003b9f05cf17 in IA__g_assertion_message (domain=<value optimized out>,
file=<value optimized out>, line=<value optimized out>, func=<value optimized out>, 
    message=<value optimized out>) at gtestutils.c:1218
#3  0x0000003b9f05d3b2 in IA__g_assertion_message_expr (domain=<value optimized
out>, file=<value optimized out>, line=<value optimized out>, func=<value
optimized out>, 
    expr=<value optimized out>) at gtestutils.c:1229
#4  0x00007fee7b9ec6e1 in ev_link_dest_from_dest (pdf_document=<value optimized
out>, dest=0x0) at ev-poppler.cc:868
#5  0x00007fee7b9ec7e9 in ev_link_from_action (pdf_document=0xd88,
action=0x1f0fb20) at ev-poppler.cc:973
#6  0x00007fee7b9eca82 in build_tree (pdf_document=0x1b2dc00, model=0x1de1480,
parent=0x0, iter=0x1f14cb0) at ev-poppler.cc:1053
#7  0x00007fee7b9ecca8 in pdf_document_links_get_links_model
(document_links=<value optimized out>) at ev-poppler.cc:1103
#8  0x000000000041df2c in ?? ()
#9  0x0000000001cefee0 in ?? ()
#10 0x0000000002027d90 in ?? ()
#11 0x0000000001cc26e0 in ?? ()
#12 0x000000000041babb in ?? ()
#13 0x0000000002027d90 in ?? ()
#14 0x0000000000c85590 in ?? () from /lib64/libpthread.so.0
---Type <return> to continue, or q <return> to quit---
#15 0x0000000000c83a60 in ?? () from /lib64/libpthread.so.0
#16 0x000000000041c05a in ?? ()
#17 0x0000000001a563c0 in ?? ()
#18 0x0000003b9f060404 in g_thread_create_proxy (data=<value optimized out>) at
gthread.c:635
#19 0x0000000000c8240a in start_thread () from /lib64/libpthread.so.0
#20 0x0000000000f7d78d in clone () from /lib64/libc.so.6
(gdb)
Comment 1 Osma Ahvenlampi 2008-03-31 03:53:52 EDT
dupes #438970
Comment 2 Nicola Soranzo 2008-03-31 11:18:30 EDT

*** This bug has been marked as a duplicate of 438970 ***

Note You need to log in before you can comment on or make changes to this bug.