Bug 439681 - gnome livecd boots then turns backlight off
gnome livecd boots then turns backlight off
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
x86_64 Linux
high Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-30 07:56 EDT by David Timms
Modified: 2008-03-31 05:17 EDT (History)
0 users

See Also:
Fixed In Version: 20080327-Snapshot
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-31 05:17:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages bzip2'ed 16kB (16.66 KB, application/octet-stream)
2008-03-30 08:12 EDT, David Timms
no flags Details
Xorg log compressed (5.80 KB, application/octet-stream)
2008-03-30 08:21 EDT, David Timms
no flags Details

  None (edit)
Description David Timms 2008-03-30 07:56:23 EDT
Description of problem:
the rhgb is shown OK. as gdm is displayed, the backlight gets turned off.

Version-Release number of selected component (if applicable):
F9Beta gnome live cd iso.

How reproducible:
3x boot ups have occurred identically.

Steps to Reproduce:
1. download live cd
2. live-cd-usb 
3. boot usb
4. machine boots {10 secs}
5. text boot up process scrolls down screen
6. rhgb: fedora-show details... finishes
  
Actual results:
looks like machine powered off. power led and battery charge leds are still lit.
on closer inspection and in the right light, backlight is off. 22:50

Expected results:
backlight on. then you could easily choose the login button.

Additional info:
notebook pc: hp compaq nx6320. issue not present with F8 up2date 2008-03-28.

waiting for the screensaver to start (since the session automatically logs in);
then mouse/kb to exit makes the backlight turn on.

can also trick the machine into backlight into turning on by _turning off_ the
notebook power supply.
Comment 1 David Timms 2008-03-30 08:12:05 EDT
Created attachment 299620 [details]
/var/log/messages bzip2'ed 16kB

Noticed some gdm debug bits so including this incase it is relevant
The machine is also offering to send kernel oopses to upstream, I let it do
this.
Comment 2 David Timms 2008-03-30 08:21:27 EDT
Created attachment 299621 [details]
Xorg log compressed

Noticed some failures at setting modes:
====
(II) intel(0): Modeline "1024x768"x0.0	 65.00	1024 1048 1184 1344  768 771
777 806 -hsync -vsync (48.4 kHz)
(II) intel(0): EDID vendor "LPL", prod id 47872
(EE) intel(0): Mode 1280x1024 does not fit virtual size 1024x1024 - internal
error
(II) intel(0): fbc disabled on plane a
====
However, without the time in there I don't know if that was occurring as gdm
started.
Comment 3 Jeremy Katz 2008-03-30 12:38:59 EDT
Can you try with the new rawhide image that went up on Friday?  This should be
fixed with it.
Comment 4 David Timms 2008-03-31 05:17:18 EDT
I retested with the torrent -
Rawhide-20080327-Snapshot-x86_64-Live
The backlight now stays on during gdm display and login, and into the user session.
Screensaver dimmed screen after 11 minutes and mouse movement woke the screen OK.
Resolved.

Note You need to log in before you can comment on or make changes to this bug.