Bug 439696 - duplicate packages
Summary: duplicate packages
Status: CLOSED DUPLICATE of bug 439680
Alias: None
Product: Fedora
Classification: Fedora
Component: PackageKit   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Robin Norwood
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-03-30 15:55 UTC by Rahul Sundaram
Modified: 2013-03-13 05:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-30 16:48:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pk-application screenshot (122.65 KB, image/png)
2008-03-30 15:55 UTC, Rahul Sundaram
no flags Details

Description Rahul Sundaram 2008-03-30 15:55:13 UTC
Description of problem:

PackageKit shows both the Fedora 8 and rawhide versions as well as somehow
differentiates between rawhide and installed versions while yum doesnt. 

Version-Release number of selected component (if applicable):

0.1.10

How reproducible:

everytime

Steps to Reproduce:

Enable fedora-development and fedora-updates.repo and disable fedora.repo. Check
the output of yum search vs pkcon name search. 
  
Actual results:

it differs

Expected results:

Behaviour should be consistent. Sample out below with a screenshot showing
pk-application behaviour. 

Additional info:

# pkcon search name alacarte

installed    alacarte             noarch  0.11.5-1.fc9    installed    Simple
menu editor for GNOME
available    alacarte             noarch  0.11.5-1.fc9    rawhide      Simple
menu editor for GNOME
search-name runtime was 2.9 second

# yum search alacarte

Loaded plugins: refresh-packagekit
============================== Matched: alacarte ===============================
alacarte.noarch : Simple menu editor for GNOME

# pkcon search name awn-extra

available    awn-extras-applets   i386    0.2.6-4.fc8     updates      Extras
applets for avant window navigator
available    awn-extras-applets   i386    0.2.6-4.fc9     rawhide      Extras
applets for avant window navigator
search-name runtime was 2.9 seconds

# yum search awn-extra

Loaded plugins: refresh-packagekit
============================== Matched: awn-extra ==============================
awn-extras-applets.i386 : Extras applets for avant window navigator

Comment 1 Rahul Sundaram 2008-03-30 15:55:13 UTC
Created attachment 299629 [details]
pk-application screenshot

Comment 2 Richard Hughes 2008-03-30 16:48:15 UTC

*** This bug has been marked as a duplicate of 439680 ***


Note You need to log in before you can comment on or make changes to this bug.