Bug 439715 - kernel-2.6.24.3-50.fc8 problems with libvirtd
kernel-2.6.24.3-50.fc8 problems with libvirtd
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
: 439901 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-30 18:02 EDT by Mihai Harpau
Modified: 2008-04-29 16:54 EDT (History)
5 users (show)

See Also:
Fixed In Version: libvirt-0.4.1-3.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-18 17:34:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
full dmesg (34.27 KB, text/plain)
2008-03-30 18:02 EDT, Mihai Harpau
no flags Details
dmesg (85.04 KB, text/plain)
2008-03-31 01:11 EDT, Srihari Vijayaraghavan
no flags Details

  None (edit)
Description Mihai Harpau 2008-03-30 18:02:35 EDT
Description of problem:

RTNL: assertion failed at net/core/fib_rules.c (627)
Pid: 4378, comm: libvirtd Not tainted 2.6.24.4-64.fc8 #1
 [<c05d38ab>] fib_rules_event+0x4a/0xf1
 [<c062ddb9>] notifier_call_chain+0x2a/0x47
 [<c04427b8>] raw_notifier_call_chain+0x17/0x1a
 [<c05c7579>] dev_set_mac_address+0x43/0x48
 [<f8f41608>] tun_chr_ioctl+0x435/0x4dd [tun]
 [<c04d5d09>] file_has_perm+0x89/0x91
 [<c04930cc>] do_ioctl+0x4c/0x62
 [<c0493319>] vfs_ioctl+0x237/0x249
 [<c0493370>] sys_ioctl+0x45/0x5d
 [<c04051da>] syscall_call+0x7/0xb
 =======================
RTNL: assertion failed at net/ipv4/devinet.c (1054)
Pid: 4378, comm: libvirtd Not tainted 2.6.24.4-64.fc8 #1
 [<c0606099>] inetdev_event+0x56/0x46e
 [<c062c1ae>] _spin_lock_bh+0x8/0x18
 [<c05e0815>] rt_run_flush+0x68/0x8f
 [<c062ddb9>] notifier_call_chain+0x2a/0x47
 [<c04427b8>] raw_notifier_call_chain+0x17/0x1a
 [<c05c7579>] dev_set_mac_address+0x43/0x48
 [<f8f41608>] tun_chr_ioctl+0x435/0x4dd [tun]
 [<c04d5d09>] file_has_perm+0x89/0x91
 [<c04930cc>] do_ioctl+0x4c/0x62
 [<c0493319>] vfs_ioctl+0x237/0x249
 [<c0493370>] sys_ioctl+0x45/0x5d
 [<c04051da>] syscall_call+0x7/0xb
 =======================


Version-Release number of selected component (if applicable):

kernel 2.6.24.4-64.fc8 (also 2.6.24.3-50.fc8)
libvirt 0.4.1-2.fc8

How reproducible:


Steps to Reproduce:
1. Run virt-manager on one kernel of above
2. Open a virtual machine based on QEMU/KVM
3. Take some time and bug will apears in log
  
Actual results:


Expected results:


Additional info:

After bug happened I see this message for many times:
vnet0: received packet with  own address as source address
Comment 1 Mihai Harpau 2008-03-30 18:02:35 EDT
Created attachment 299643 [details]
full dmesg
Comment 2 Srihari Vijayaraghavan 2008-03-31 00:55:11 EDT
Same here, with one major observation: the network connectivity between the host
& guest is lost (the error message "vnet0: port 1(vnet1) entering disabled
state" implies that I think).
Comment 3 Srihari Vijayaraghavan 2008-03-31 01:11:08 EDT
Created attachment 299687 [details]
dmesg

it captures many error messages (suspected to be related to the lost network
connection between host & guest)
Comment 4 Srihari Vijayaraghavan 2008-03-31 01:18:32 EDT
Mihai Harpau (mishu@piatafinanciara.ro): could you please raise the severity of
this bug to 'high', as in my case with no network connectivity between the host
& guest, it really is a high severity bug (because I'm no owner of this bug, it
doesn't let me).
Comment 5 Mihai Harpau 2008-03-31 05:54:35 EDT
I my case there is a lost network connectivity between host and a guest that run
winXP but also there is good network connectivity between host and a guest that
run F9beta.
Comment 6 thanosz 2008-03-31 08:29:07 EDT
This is indeed high priority since network connectivity between guests is lost!
Workarround is to downgrade to 3.3.3-2.fc8 libvirt, libvirt-python 
Comment 7 Mihai Harpau 2008-03-31 08:46:40 EDT
(In reply to comment #6)
> This is indeed high priority since network connectivity between guests is lost!
> Workarround is to downgrade to 3.3.3-2.fc8 libvirt, libvirt-python 

I think the version of libvirt that you could downgrade is 0.4.0-4.fc8 and
indeed doesn't exhibit the same problem.
Comment 8 Carl Farrington 2008-03-31 17:43:04 EDT
Same problem here. My XP Pro VM has no network connectivity, although it does
manage to obtain an IP address from the virtual DHCP server.

Everything was fine until a reboot. I am fairly sure it is a result of the
libvirt updates that came through over the last couple of days (29th, 30th March).
Comment 9 Dave Jones 2008-03-31 18:23:27 EDT
*** Bug 439901 has been marked as a duplicate of this bug. ***
Comment 10 Lubomir Kundrak 2008-03-31 23:59:36 EDT
In case it is of any use, the problem also occurs with 2.6.23.15-137.fc8.
Comment 11 thanosz 2008-04-01 03:56:39 EDT
Some extra info: In my case, the host (FC8) can communicate with all guests
(2xSLES10_x86_64, SLES9_i386) but the guests cannot communicate with each other.
(default iptables pilicies are ACCEPT).
Comment 12 Carl Farrington 2008-04-01 05:50:18 EDT
Quick fix if you're not too sure what you're doing (like me!). I'm not sure 
where previous updates are meant to come from, because all the mirrors that I 
look at only have the latest version of packages in their updates direcetory, 
but anyway I found a mirror which isn't quite so up to date:
ftp://ftp.is.co.za/mirror/fedora.redhat.com/linux/updates/8/x86_64/

(I am using x86_64 .. you may want i386 if not)

Grab the previous versions of libvirt and libvirt-python from there:
libvirt-0.4.0-4.fc8.x86_64.rpm
libvirt-python-0.4.0-4.fc8.x86_64.rpm

(again.. you may want i386..)

cd to the directory you downloaded those two packages to, then:

rpm -U --oldpackage ./libvirt-0.4.0-4.fc8.x86_64.rpm ./libvirt-python-0.4.0-
4.fc8.x86_64.rpm

Now my VM has networking again.
Comment 13 Mihai Harpau 2008-04-01 05:59:27 EDT
All previous updates and builds for libvirt(for F7 and F8 anyway) are found here:
http://koji.fedoraproject.org/koji/packageinfo?packageID=91
Comment 14 Chuck Ebbert 2008-04-02 22:57:12 EDT
Fixed the locking in 2.6.24.4-73, but that may not make any real difference. At
least the failed assertions should be gone.
Comment 15 Mihai Harpau 2008-04-03 16:22:26 EDT
Right, messages with "assertion failed" are gone in kernel-2.6.24.3-74.fc8. But
message "vnet0: received packet with  own address as source address" remains and
also the related problems (vm guest lost connectivity, etc.) are not gone.
Comment 16 Carl Farrington 2008-04-17 04:44:34 EDT
New libvirt update says it fixes this problem, but they don't mention this
particular bug id:
https://admin.fedoraproject.org/updates/F8/FEDORA-2008-2915
Comment 17 Mihai Harpau 2008-04-17 05:22:52 EDT
I can confirm that this bug is fixed in libvirt-0.4.1-3.fc8
Comment 18 Lubomir Kundrak 2008-04-17 05:47:04 EDT
No, this was not fixed, and couldn't be fixed in libvirt, only worked around.
This is a kernel problem, and should be fixed in kernel.
Comment 19 Chuck Ebbert 2008-04-18 16:46:31 EDT
(In reply to comment #18)
> No, this was not fixed, and couldn't be fixed in libvirt, only worked around.
> This is a kernel problem, and should be fixed in kernel.

What is a kernel problem? The bogus RTNL assertions are gone, what is left?
Comment 20 Lubomir Kundrak 2008-04-18 17:34:02 EDT
Chuck, oh, sorry -- I did not notice. Closing again then.
Comment 21 Fedora Update System 2008-04-21 20:04:35 EDT
kernel-2.6.24.5-85.fc8 has been submitted as an update for Fedora 8
Comment 22 Fedora Update System 2008-04-29 16:54:24 EDT
kernel-2.6.24.5-85.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.