Bug 439753 - Sierra MC5720 appears as 3 CDMA networks
Sierra MC5720 appears as 3 CDMA networks
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hal-info (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-31 03:13 EDT by Jeremy Fitzhardinge
Modified: 2008-04-02 10:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-02 07:57:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lsusb output for Sierra MC5720 (3.89 KB, text/plain)
2008-03-31 03:13 EDT, Jeremy Fitzhardinge
no flags Details
lshal output (139.63 KB, text/plain)
2008-03-31 12:06 EDT, Jeremy Fitzhardinge
no flags Details

  None (edit)
Description Jeremy Fitzhardinge 2008-03-31 03:13:12 EDT
Description of problem:
Sierra Wireless, Inc. MC5720 Wireless Modem appears three times as CDMA network

Version-Release number of selected component (if applicable):
NetworkManager-0.7.0-0.9.1.svn3476.fc9.i386

How reproducible:
All the time

Steps to Reproduce:
1. Enable MC5720
2. Observe three "Auto CDMA network connection" entries in nm-applet list
3.
  
Actual results:
Three CDMA networks

Expected results:
One CDMA network

Additional info:
The MC5720 presents three USB device endpoints, but only the first one is used
for PPP connections.
Comment 1 Jeremy Fitzhardinge 2008-03-31 03:13:12 EDT
Created attachment 299689 [details]
lsusb output for Sierra MC5720
Comment 2 Dan Williams 2008-03-31 11:57:51 EDT
Could you attach the output of 'lshal' instead?  It's actually a HAL-info bug;
all serial ports are getting tagged as modems when really only one should be.
Comment 3 Jeremy Fitzhardinge 2008-03-31 12:06:22 EDT
Created attachment 299734 [details]
lshal output
Comment 4 Dan Williams 2008-03-31 14:47:48 EDT
Can you try hal-info-20080317-3 when it hits koji?

http://koji.fedoraproject.org/koji/taskinfo?taskID=540361

should be done now, please test.
Comment 5 Jeremy Fitzhardinge 2008-04-02 03:23:38 EDT
No, hal-info-20080317-3.fc9.noarch doesn't help.
Comment 6 Dan Williams 2008-04-02 07:57:37 EDT
Ugh, that would be because I screwed up the patch application.  Thanks for the
heads-up.

Fixed builds here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=543861
Comment 7 Jeremy Fitzhardinge 2008-04-02 10:16:17 EDT
Fixed, thanks.

Note You need to log in before you can comment on or make changes to this bug.