Bug 439767 - [5.2][kdump] crash failed to read vmcore from SGI Altix
[5.2][kdump] crash failed to read vmcore from SGI Altix
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kexec-tools (Show other bugs)
5.2
ia64 Linux
medium Severity medium
: rc
: ---
Assigned To: Neil Horman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-31 06:34 EDT by CAI Qian
Modified: 2008-05-21 11:23 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0313
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:23:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backport patch (1.47 KB, patch)
2008-03-31 06:34 EDT, CAI Qian
no flags Details | Diff

  None (edit)
Description CAI Qian 2008-03-31 06:34:07 EDT
Description of problem:
crash returned error when reading vmcore generated by kexec-tools-1.102pre-16.el5,

[root@altix4 SOURCES] crash /usr/lib/debug/lib/modules/2.6.18-86.el5/vmlinux
/var/crash/2008-03-29-03\:01/vmcore

crash: read error: kernel virtual address: a000000100cc9f00  type: "xtime"

However, there is no such problem if using RHEL5U1 version
kexec-tools-1.101-194.el5.

Version-Release number of selected component (if applicable):
RHEL5.2-Server-20080326.nightly
kexec-tools-1.102pre-16.el5
kernel-2.6.18-86.el5
crash-4.0-5.0.2

How reproducible:
Always (can try altix4.rhts.boston.redhat.com)

Steps to Reproduce:
1. configure kdump with crashkernel=512M@256M.
2. SysRq-C
3. use crash to exam vmcore.

Additional info:
Looks like a known bug from upstream,
https://lists.linux-foundation.org/pipermail/fastboot/2007-March/013645.html
http://git.kernel.org/?p=linux/kernel/git/horms/kexec-tools-testing.git;a=commit;h=f4bf231af8a8c29ba0908551ed7582b5dc33586d

I have verified the following backport patch for kexec-tools-1.102pre-16.el5
fixed the problem, and crash read it correctly.

      KERNEL: /usr/lib/debug/lib/modules/2.6.18-86.el5/vmlinux
    DUMPFILE: /var/crash/2008-03-31-06:04/vmcore
        CPUS: 4
        DATE: Mon Mar 31 06:03:26 2008
      UPTIME: 00:34:10
LOAD AVERAGE: 0.37, 0.17, 0.09
       TASKS: 113
    NODENAME: altix4.rhts.boston.redhat.com
     RELEASE: 2.6.18-86.el5
     VERSION: #1 SMP Tue Mar 18 18:21:07 EDT 2008
     MACHINE: ia64  (1500 Mhz)
      MEMORY: 7.1 GB
       PANIC: "SysRq : Trigger a crashdump"
         PID: 2824
     COMMAND: "bash"
        TASK: e0000030f0fd0000  [THREAD_INFO: e0000030f0fd1040]
         CPU: 1
       STATE: TASK_RUNNING (SYSRQ)
Comment 1 CAI Qian 2008-03-31 06:34:07 EDT
Created attachment 299695 [details]
backport patch
Comment 2 Neil Horman 2008-03-31 09:21:36 EDT
Ok, requesting exception (not sure if this will make it though, as I can't
recall what the last snapshot date is)
Comment 4 CAI Qian 2008-04-02 23:25:04 EDT
This is a regression against RHEL5U1, so propose for RHEL5U2 rc-blocker.
Comment 11 errata-xmlrpc 2008-05-21 11:23:32 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0313.html

Note You need to log in before you can comment on or make changes to this bug.