Bug 439839 - lam install scripts creates invalid symbolic links
lam install scripts creates invalid symbolic links
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: lam (Show other bugs)
4.6
All Linux
medium Severity medium
: rc
: ---
Assigned To: Doug Ledford
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-31 13:26 EDT by Milos Malik
Modified: 2008-07-24 15:10 EDT (History)
0 users

See Also:
Fixed In Version: RHEA-2008-0662
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 15:10:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2008-03-31 13:26:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; cs-CZ; rv:1.8.1.13) Gecko/20080325 Fedora/2.0.0.13-1.fc8 Firefox/2.0.0.13

Description of problem:
Almost each binary package which comes from lam-*.src.rpm creates during its installation invalid symbolic links.

This problem was NOT observed on s390 and s390x machines. All other architectures has this problem.

Version-Release number of selected component (if applicable):
lam-7.1.2-8

How reproducible:
Always


Steps to Reproduce:
1. remove all lam packages from current machine
2. remove all openmpi packages from current machine
3. rm -f /etc/ld.so.conf.d/mpi* # because these files are broken symlinks
4. rm -f /etc/alternatives/mpi* # because these files are broken symlinks
5. rm -f /usr/bin/mpi*          # because these files are broken symlinks
6. up2date -i lam lam-devel
7. ls -l /etc/ld.so.conf.d/mpi*
8. ls -l /etc/alternatives/mpi*
9. ls -l /usr/bin/mpi*


Actual Results:
Invalid symbolic links in directories:

/etc/ld.so.conf.d/
/etc/alternatives/
/usr/bin/

Expected Results:
Valid symbolic links in directories:

/etc/ld.so.conf.d/
/etc/alternatives/
/usr/bin/

Additional info:
Comment 1 Milos Malik 2008-04-01 09:29:16 EDT
One of the affected machines is ia64-4as-6-m1.lab.boston.redhat.com:

# ls -lL /etc/alternatives/mpi*
ls: /etc/alternatives/mpic++: No such file or directory
ls: /etc/alternatives/mpicc: No such file or directory
ls: /etc/alternatives/mpiCC: No such file or directory
ls: /etc/alternatives/mpicxx: No such file or directory
ls: /etc/alternatives/mpif77: No such file or directory
ls: /etc/alternatives/mpif90: No such file or directory
ls: /etc/alternatives/mpilibs64: No such file or directory
-rwxr-xr-x  1 root root 19941 Oct 21  2006 /etc/alternatives/mpi-exec
-rw-r--r--  1 root root  3280 Oct 21  2006 /etc/alternatives/mpi-exec-man
-rwxr-xr-x  1 root root 51872 Oct 21  2006 /etc/alternatives/mpi-run
-rw-r--r--  1 root root 10184 Oct 21  2006 /etc/alternatives/mpi-run-man

# ls -lL /usr/bin/mpi*
ls: /usr/bin/mpic++: No such file or directory
ls: /usr/bin/mpicc: No such file or directory
ls: /usr/bin/mpiCC: No such file or directory
ls: /usr/bin/mpicxx: No such file or directory
ls: /usr/bin/mpif77: No such file or directory
ls: /usr/bin/mpif90: No such file or directory
-rwxr-xr-x  1 root root 19941 Oct 21  2006 /usr/bin/mpiexec
-rwxr-xr-x  1 root root 51872 Oct 21  2006 /usr/bin/mpirun

# ls -lL /etc/ld.so.conf.d/mpi*
ls: /etc/ld.so.conf.d/mpi64.conf: No such file or directory
Comment 4 Gurhan Ozen 2008-06-13 03:13:41 EDT
This is solved with the mpi-selector program introduced with errata 2008:8311 
Comment 6 errata-xmlrpc 2008-07-24 15:10:13 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2008-0662.html

Note You need to log in before you can comment on or make changes to this bug.