Bug 439900 - trademark sign in rpm summary crashes anaconda during install
trademark sign in rpm summary crashes anaconda during install
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i686 Linux
low Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-31 18:06 EDT by Jacek Pliszka
Modified: 2013-01-09 23:38 EST (History)
2 users (show)

See Also:
Fixed In Version: F9-Preview
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-23 15:40:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jacek Pliszka 2008-03-31 18:06:01 EDT
Description of problem:

Summary field of the rpm contains unicode character - trademark sign
that crashes Fedora 9 installation. The fastest solution would be to
remove it.

Version-Release number of selected component (if applicable):
rt73usb-firmware-1.8-4.noarch.rpm

How reproducible:

Install Fedora 9 with standard package selection.

Steps to Reproduce:
1. Do a fresh install of fedora core 9
2. install crashes during installation of rt73usb-firmware-1.8-4.noarch.rpm
package
3.
  
Actual results:

Anaconda crash

Expected results:

F9 installation successfull

Additional info:

Either anaconda needs a fix or just remove the trademark sign from 
Summary filed in the rpm
Comment 1 Jesse Keating 2008-03-31 18:20:40 EDT
I expect you were doing an install in text or serial mode?
Comment 2 Jacek Pliszka 2008-03-31 18:43:58 EDT
YEs, text mode.

Unfortunately there is another bug in GUI install I haven't debugged yet. :(
Comment 3 Jacek Pliszka 2008-03-31 18:50:39 EDT
Bug is actually in line 160 in yuminstall.py in anaconda:

s+= (hdr['summary'] or "")
Comment 4 Jeremy Katz 2008-03-31 18:59:52 EDT
This should be fixed in newer rawhide (say the middle of last week or so).  Are
you still seeing it?

If not, dupe of bug 437993
Comment 5 Jacek Pliszka 2008-04-23 15:40:34 EDT
It is fixed in F9-Preview. 

Sorry I could not check it earlier but I have bittorrent blocked so I had to
wait for something usable with jigdo.

Note You need to log in before you can comment on or make changes to this bug.