Bug 439901 - kernel call trace from virtual network device
kernel call trace from virtual network device
Status: CLOSED DUPLICATE of bug 439715
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-31 18:17 EDT by Michael E Brown
Modified: 2008-03-31 18:23 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-31 18:23:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
full dmesg output (31.90 KB, text/plain)
2008-03-31 18:17 EDT, Michael E Brown
no flags Details

  None (edit)
Description Michael E Brown 2008-03-31 18:17:17 EDT
Description of problem:

kernel call trace:
tun: Universal TUN/TAP device driver, 1.6
tun: (C) 1999-2004 Max Krasnyansky <maxk@qualcomm.com>
RTNL: assertion failed at net/core/fib_rules.c (627)
Pid: 2855, comm: libvirtd Not tainted 2.6.24.3-50.fc8 #1

Call Trace:
 [<ffffffff812077e5>] fib_rules_event+0x4e/0x119
 [<ffffffff8126b75d>] notifier_call_chain+0x29/0x4c
 [<ffffffff811fa80c>] dev_set_mac_address+0x4b/0x52
 [<ffffffff88517653>] :tun:tun_chr_ioctl+0x451/0x50a
 [<ffffffff810fa199>] file_has_perm+0x94/0xa3
 [<ffffffff810ac039>] do_ioctl+0x55/0x6b
 [<ffffffff810ac292>] vfs_ioctl+0x243/0x25c
 [<ffffffff810ac2fc>] sys_ioctl+0x51/0x71
 [<ffffffff8100be8e>] system_call+0x7e/0x83

RTNL: assertion failed at net/ipv4/devinet.c (1054)
Pid: 2855, comm: libvirtd Not tainted 2.6.24.3-50.fc8 #1

Call Trace:
 [<ffffffff8123f5f1>] inetdev_event+0x59/0x46a
 [<ffffffff8126983f>] _spin_lock_bh+0x9/0x19
 [<ffffffff81216ce4>] rt_run_flush+0x7f/0xb7
 [<ffffffff8126b75d>] notifier_call_chain+0x29/0x4c
 [<ffffffff811fa80c>] dev_set_mac_address+0x4b/0x52
 [<ffffffff88517653>] :tun:tun_chr_ioctl+0x451/0x50a
 [<ffffffff810fa199>] file_has_perm+0x94/0xa3
 [<ffffffff810ac039>] do_ioctl+0x55/0x6b
 [<ffffffff810ac292>] vfs_ioctl+0x243/0x25c
 [<ffffffff810ac2fc>] sys_ioctl+0x51/0x71
 [<ffffffff8100be8e>] system_call+0x7e/0x83


Version-Release number of selected component (if applicable):

$ uname -a
Linux duo 2.6.24.3-50.fc8 #1 SMP Thu Mar 20 13:39:08 EDT 2008 x86_64 x86_64
x86_64 GNU/Linux

How reproducible:

unsure. This is the first I've seen it. I was about to enter another bug about
KVM crashing my machine and I noticed this in dmesg.


Steps to Reproduce:

Appears to have happened when i activated the virtual network device for KVM
Comment 1 Michael E Brown 2008-03-31 18:17:17 EDT
Created attachment 299777 [details]
full dmesg output
Comment 2 Dave Jones 2008-03-31 18:23:26 EDT

*** This bug has been marked as a duplicate of 439715 ***

Note You need to log in before you can comment on or make changes to this bug.