Bug 439928 - Can't install Evolution due to missing libgtkhtml libegroupwise and libexchange-storage
Can't install Evolution due to missing libgtkhtml libegroupwise and libexchan...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Channels (Show other bugs)
RHN Devel
i386 Linux
low Severity low
: ---
: ---
Assigned To: Mike Orazi
Amy Owens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-31 20:17 EDT by Thomas Cameron
Modified: 2010-10-22 19:36 EDT (History)
4 users (show)

See Also:
Fixed In Version: 5.0.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-16 09:42:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Cameron 2008-03-31 20:17:07 EDT
Description of problem:
Tried to install Evolution and there are missing dependencies.

Version-Release number of selected component (if applicable):
RHEL 5.2 AP (beta)

How reproducible:
yum install evolution

Steps to Reproduce:
1.yum install evolution
2.
3.
  
Actual results:
[tcameron@tct60 ~]$ sudo yum install evolution
Loading "security" plugin
Loading "rhnplugin" plugin
rhel-i386-server-5        100% |=========================| 1.4 kB    00:00     
rhel-i386-server-hts-5-be 100% |=========================| 1.2 kB    00:00     
rhel-i386-server-producti 100% |=========================| 1.2 kB    00:00     
rhel-i386-server-producti 100% |=========================| 1.2 kB    00:00     
rhel-i386-server-5-beta   100% |=========================| 1.2 kB    00:00     
rhel-i386-server-fastrack 100% |=========================| 1.2 kB    00:00     
rhel-i386-server-vt-5-bet 100% |=========================| 1.2 kB    00:00     
rhn-tools-rhel-i386-serve 100% |=========================| 1.2 kB    00:00     
rhel-i386-server-suppleme 100% |=========================| 1.2 kB    00:00     
rhel-i386-server-cluster- 100% |=========================| 1.4 kB    00:00     
rhel-i386-server-suppleme 100% |=========================| 1.4 kB    00:00     
rhel-i386-server-vt-5     100% |=========================| 1.4 kB    00:00     
rhel-i386-server-cluster- 100% |=========================| 1.2 kB    00:00     
rhel-i386-server-hts-5    100% |=========================| 1.2 kB    00:00     
rhel-i386-server-cluster- 100% |=========================| 1.2 kB    00:00     
rhel-i386-server-cluster- 100% |=========================| 1.4 kB    00:00     
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package evolution.i386 0:2.8.0-40.el5_1.1 set to be updated
--> Processing Dependency: libegroupwise-1.2.so.12 for package: evolution
--> Processing Dependency: libexchange-storage-1.2.so.2 for package: evolution
--> Processing Dependency: gnome-pilot >= 2.0.13 for package: evolution
--> Processing Dependency: libgtkhtml-3.8.so.15 for package: evolution
--> Processing Dependency: gnome-spell >= 1.0.2 for package: evolution
--> Processing Dependency: libgpilotd.so.2 for package: evolution
--> Processing Dependency: libgpilotdcm.so.2 for package: evolution
--> Processing Dependency: libgpilotdconduit.so.2 for package: evolution
--> Processing Dependency: libpisock.so.8 for package: evolution
--> Processing Dependency: libpisync.so.0 for package: evolution
--> Running transaction check
---> Package gnome-pilot.i386 0:2.0.13-16 set to be updated
---> Package evolution.i386 0:2.8.0-40.el5_1.1 set to be updated
--> Processing Dependency: libegroupwise-1.2.so.12 for package: evolution
--> Processing Dependency: libexchange-storage-1.2.so.2 for package: evolution
--> Processing Dependency: libgtkhtml-3.8.so.15 for package: evolution
---> Package pilot-link.i386 2:0.11.8-16 set to be updated
---> Package gnome-spell.i386 0:1.0.7-3.1 set to be updated
--> Finished Dependency Resolution
Error: Missing Dependency: libgtkhtml-3.8.so.15 is needed by package evolution
Error: Missing Dependency: libegroupwise-1.2.so.12 is needed by package evolution
Error: Missing Dependency: libexchange-storage-1.2.so.2 is needed by package
evolution


Expected results:
evolution installs

Additional info:
I am subscribed to every production and beta channel on RHN
Comment 1 Matthew Barnes 2008-03-31 23:29:30 EDT
It looks like you're only pulling packages from RHEL 5.2 Server.  Evolution
itself is only in RHEL 5.2 Client, but it's base libraries are included in
Server.  I think you just need to grab the newer Evolution RPMs from Client.
Comment 2 Michal Babej 2008-04-01 04:06:39 EDT
Actually 5.2 Server has Evolution (in "optional productivity apps" channel), but
only for i386 & x86_64 archs.

Interesting:
---> Package evolution.i386 0:2.8.0-40.el5_1.1 set to be updated

Somehow yum wants to install old evolution (5.2 contains evo 2.12) and can't
find dependencies for it. Maybe you have some old channel subscribed, or
channel's misconfiguration...
Comment 3 Thomas Cameron 2008-04-01 17:22:28 EDT
It seems the channel is misconfigured.  I am subscribed to the RHEL Optional
Productivity Apps (v. 5 for 32-bit x86) Beta channel but there is no content!

Evo 2.8 is still in the RHEL Optional Productivity Apps (v. 5 for 32-bit x86)
channel but 2.12 is not yet in the beta channel.  Should this be reassigned to
the RHN folks?
Comment 4 Matthew Barnes 2008-04-01 19:54:29 EDT
It does sound like an RHN problem.
Comment 6 Matthew Barnes 2008-04-14 10:54:13 EDT
Reassigning this to Red Hat Network.
Comment 7 Amy Owens 2008-04-14 11:58:26 EDT
sending off to release engineering

Note You need to log in before you can comment on or make changes to this bug.