Bug 439947 - Reopen a bug will reset the package check status to be unchecked
Reopen a bug will reset the package check status to be unchecked
Status: CLOSED CURRENTRELEASE
Product: Red Hat Ready Certification Tests
Classification: Retired
Component: web site (Show other bugs)
2
All Linux
high Severity medium
: ---
: ---
Assigned To: XINSUN
Yu Shao
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-31 22:34 EDT by QinXie
Modified: 2008-06-23 03:32 EDT (History)
5 users (show)

See Also:
Fixed In Version: (2.18rh) 2008/05/23 push
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-23 03:32:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Bug fix patch (651 bytes, patch)
2008-04-14 02:06 EDT, XINSUN
no flags Details | Diff

  None (edit)
Description QinXie 2008-03-31 22:34:56 EDT
Description of problem:
Reopen a bug will reset the package check status

Steps to Reproduce:
1. Open one cert and upload some rpm packages there;
2. Check all package and then close this cert as certified;
3. Reopen the certs
  
Actual results:
All packages are reseted to be unchecked. 

Expected results:
Auto generate one reopen comment including operator & time stamp. But packages
status should keep the old value but all unchecked.
Comment 1 XINSUN 2008-04-14 02:04:08 EDT
The bug is caused by the variable of the bug status for judging condition is not
correct (When reopen this bugs, the bug status should be changed from close to
needinfo. and the judging condition: old bug status should eq "close".) The
fixed method pls refer to the attached patch(checkrpm.patch).

After patch it, packages
"check" status can keep the old value but all unchecked when reopen the cert.

"Auto generate one reopen comment including operator & time stamp" is not
recommended. because Bugzilla can reminder people who are related to the cert
via mail.

Best Regards!
Nicho
Comment 2 XINSUN 2008-04-14 02:06:44 EDT
Created attachment 302307 [details]
Bug fix patch
Comment 3 XINSUN 2008-05-14 09:16:03 EDT
Patch has been summited into cvs.

Note You need to log in before you can comment on or make changes to this bug.