Bug 439998 - Graphic + Layout + gnome-keyboard-properties
Graphic + Layout + gnome-keyboard-properties
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Control Center Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-01 05:56 EDT by Jóhann B. Guðmundsson
Modified: 2008-05-05 02:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-05 02:13:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jóhann B. Guðmundsson 2008-04-01 05:56:31 EDT
Description of problem:

Graphical errors in System -- Preference -- Hardware -- Keyboard -- Layouts -- Add
fields are just white..

Should display the default or last configured keyboard layout ( us + inet )

choose layout -- long white empty space on top of the first country )
print screen seems to be disabled when one has clicked layout.. 
cant press the first letter of a country ( pressing u should take you
to the first country that starts with U )

Version-Release number of selected component (if applicable):


How reproducible:
Always
Present in F8 and Alpha Beta and Rawhide

Steps to Reproduce:
1. System --> Preference --> Hardware --> Keyboard --> Layouts --> Add
2.
3.
  
Actual results:


Expected results:

Default or last configured layout being shown ( chosen ) 
no empty white space on top of the country list.
Pressing A should bring you to the first country starting with A
Screenshot should work ( print screen )

Additional info:
Comment 1 Matthias Clasen 2008-05-05 02:13:02 EDT
This is just how combo boxes work in GTK+
Comment 2 Jóhann B. Guðmundsson 2008-05-05 02:44:29 EDT
What do you mean this is just how combo boxes work in GTK+?

So are you saying that this is not fixable.

The code that "disables" taking screenshots with print screen 
cant be fixed.

The code the sets the size/hight of the country box cant be fixed?

The missing code to add the support for pressing a letter that takes
you to the first country that starts with that letter cant be added? 
( see how it works when you select keyboard layout in anaconda ).

????


Note You need to log in before you can comment on or make changes to this bug.