Bug 440064 - smoltSendProfile traceback: Critical [20]: Invalid Token
Summary: smoltSendProfile traceback: Critical [20]: Invalid Token
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: smolt   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Mike McGrath
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-01 16:02 UTC by ericm24x7
Modified: 2008-04-22 16:16 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-22 16:16:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of "time smoltSendProfile -a" (4.50 KB, application/octet-stream)
2008-04-02 05:44 UTC, ericm24x7
no flags Details
output with error message (4.44 KB, application/octet-stream)
2008-04-02 16:15 UTC, ericm24x7
no flags Details

Description ericm24x7 2008-04-01 16:02:52 UTC
Description of problem:
Using the latest fc9 build, dated 4/1/08, running command line smoltSendProfile
failed to send, showing the following traceback:

Send this information to the Smolt server? (y/n) y
Server Message: "Critical [20]: Invalid Token"
Traceback (most recent call last):
  File "/usr/bin/smoltSendProfile", line 175, in <module>
    timeout=opts.timeout)
  File "/usr/share/smolt/client/smolt.py", line 468, in send
    pub_uuid = serverMessage(o.read())
  File "/usr/share/smolt/client/smolt.py", line 305, in serverMessage
    raise ServerError, _('Could not contact server: %s') %
line.split('ServerMessage: ')[1]
smolt.ServerError: 'Could not contact server: Critical [20]: Invalid Token'

NOTE: running "smoltGui" works OK.

Version-Release number of selected component (if applicable):
smolt.noarch 1.1.1.1-1.fc9

How reproducible:
persistent

Steps to Reproduce:
1. run command line:  smoltSendProfile
2.
3.
  
Actual results:
displayed traceback shown above.

Additional info:
running the gui program works OK (smoltGui).

Comment 1 Mike McGrath 2008-04-01 16:19:40 UTC
Please run it a few times with "time":

time smoltSendProfile -a

And tell me what you get.

Comment 2 ericm24x7 2008-04-02 05:44:39 UTC
Created attachment 300011 [details]
output of "time smoltSendProfile -a"

Comment 3 Mike McGrath 2008-04-02 13:22:14 UTC
The log submitted seems to have completed successfully.  Is that correct?  If so
I suspect either network issues or server load when you first submitted.

Comment 4 ericm24x7 2008-04-02 16:15:40 UTC
Created attachment 300089 [details]
output with error message

Comment 5 ericm24x7 2008-04-02 16:17:37 UTC
Comment on attachment 300089 [details]
output with error message

yes, looks like server load problem. I tried re-running the command this
morning and output returns error message

Comment 6 Mike McGrath 2008-04-02 16:22:47 UTC
We've got a fix out to spread the load more evenly but people don't update as
often as they should so, unfortunately, the first 3 days of the month are always
bad.


Note You need to log in before you can comment on or make changes to this bug.